-   Red Hat (
-   -   PXE kickstart problem with rhel6 (

gusthecat 03-16-2012 02:40 PM

PXE kickstart problem with rhel6
We have custom RH5 PXE kickstarts via nfs that work great. Now I'm trying to setup, on the same nfs system, a RH6 PXE KS but I'm running into this error.

The file *.rpm cannot be opened. This is due to a missing file, corrupted package or corrupted media.

The PXE boots, downloads the .cfg file and does everything in there. It then does the "checking dependencies" step successfully, but as soon as it starts to try and install the packages the above message is displayed. I think this is a missing file issue, I can install the rpms from the nfs location, but I don't understand why. I setup the tree like a rh6 dvd, which is different from a rh5 dvd.

How can I troubleshoot this? It would be nice to actually see where the process is looking for the rpms


trey85stang 03-16-2012 02:53 PM

I ran into this a while back unfortunately I do not recall what I did to fix this issue (i think it was nic settings in the pxe file ala eth_options="auto neg off..etc")... however it is not a missing file issue. Try hitting enter a few times to the message and it will move past it and install the file.

gusthecat 03-20-2012 09:24 AM

I tried hitting enter several times but it never moved past.

After spending a day of frustration I really think it something to do with creating the repository metadata.

If I take the contents of a rhel 6 iso and add it to my pxe server it works. You can boot to the PXE and install. The problem occurs when I add a custom group to the comps.xml and run createrepo to regenerate the repo metadata.

My PXE server is running rh5 and I was using the createrepo tool on it for the rh6 kickstart.
But I found in the rh6 deployment guide that will not work. Full explanation here

So I built a rh6 system, ran createrepo there and moved everything back to my rh5 pxe server and I got the same result.
What am I missing?

onebuck 03-20-2012 11:41 AM

Moderator response
Moved: This thread is more suitable in <Red Hat> and has been moved accordingly to help your thread/question get the exposure it deserves.

mikey99 03-23-2012 06:10 AM

I rememeber on RHEL5, the directory structure of a repo was


On RHEL6 it is


Then run


# createrepo /path/to/repo


gusthecat 03-23-2012 07:43 AM

Thanks that confirms what I found but it was stated another way.

Instructions for createrepo are not correct when you need to create bootable DVD
path/to/RPMs should be path/to/root/of/DVD

All times are GMT -5. The time now is 01:03 PM.