-   Red Hat (
-   -   Problems as non-root user (

mansourk 01-26-2013 01:30 AM

Problems as non-root user
Hi All,

Recently i installed Centos 6 with Gnome on my PC and later on updated it to version 6.3, everything was fine at the beggining, but then i've got these problems: I can't run some apps like evince and when i try to run it from terminal i get segmentation fault error. or when i click on System tab in Gnome-system-monitor it crashes. Some of the gnome panel applets like trash, clock, desktop switcher has been disappeared from my gnome-panel and when i click on "Add to panel" nothing happens and the applets list doesn't show up. I also installed Openbox but when i choose it on login screen i get a black screen for a few seconds and get back to login screen again.
The things are OK when i login as root; i can login to Openbox, and when i login to Gnome the gnome panel is alright and i can run evince... It looks like some permission issue, but i can't figure it out. I don't know if that's relevant but i changed my root password with "passwd" to my regular-account/sudo password at some point.
This is what i got when i issued "uname -a" in terminal:

Linux dhcppc0 2.6.32-279.19.1.el6.x86_64 #1 SMP Wed Dec 19 07:05:20 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

shivaa 01-26-2013 01:42 AM

Once kill gnome panel and re-launch:

~$ ps -Af | grep gnome-panel
~$ kill -9 <pid>
~$ gnome-panel &

Check if it makes any difference.

mansourk 01-26-2013 06:28 AM

Thanks for the quick reply. I did your recipe but when i kill gnome-panel
it restarts automtically the same as before.

shivaa 01-26-2013 07:11 AM

Well, it sounds some issue with your gnome profile. As a workaround you can try to reset it as:

~$ ls -la | egrep ".gno|.gcon"
It will list out your gnome setup files like .gnome, .gnome2, .gconf, .gconfd etc. for your profile.
So move all 5 or 6 files into some directory, as:

~$ mkdir ~/gnome_archive
~$ mv .gnome .gnome2 .gconf .gconfd ~/gnome_archive

And then once logout and login again. It will generate new files for gnome setup. It will certainly help you.

mansourk 01-26-2013 08:53 AM

I did reset my gnome profile as you said, but still i'm having the problems in my gnome
session. After i logged in again i listed my gnome setup files:

[mansour@dhcppc3 ~]$ ls -la | egrep ".gno|.gcon"
drwx------.  4 mansour mansour  4096 Jan 26 16:54 .gconf
drwx------.  2 mansour mansour  4096 Jan 26 16:57 .gconfd
drwx------.  6 mansour mansour  4096 Jan 26 16:55 .gnome2
drwx------.  2 mansour mansour  4096 Jan 26 16:55 .gnome2_private
drwxrwxr-x.  7 mansour mansour  4096 Jan 26 16:51 gnome_archive

They are not exactly the same as yours but i dont know if that's the problem.
I'm still seeing more problems, for example in the "Apearance preferences" window when
i click on Background tab the window crashes.
I'm also not able to open pdf files with evince by double clicking on them. I tried launching evince from terminal, it only worked with sudo (although it gives a warning):

]$ evince
Segmentation fault
 $ sudo evince
** (evince:5218): WARNING **: Failed to create dbus proxy for org.gnome.SettingsDaemon: Could not get owner of name 'org.gnome.SettingsDaemon': no such name

Again when i login as root everything is working properly.

shivaa 01-26-2013 09:17 AM

No need to alter gnome files anymore. Application crashes may happen because of low disk or user quota issue.

Can you once check your user quota (if applicable) and disk space?

~$ quota <uername>
~$ df -k

mansourk 01-26-2013 12:16 PM

Checking disk quota didn't return any outputs whereas "df -k" produced:

Filesystem          1K-blocks      Used Available Use% Mounted on
                      51606140  3413740  47668332  7% /
tmpfs                  763756      124    763632  1% /dev/shm
/dev/sda1              495844    53300    416944  12% /boot
                      21778996  3922536  16750132  19% /home

John VV 01-26-2013 03:40 PM

by chance did you install third party repos ?
like say rpmforge ? or epel ? or ELrepo ? or some other

some repos have incompatible rpm's in them
because of this the yum plugin "yum-priorities" needs to be installed AND CONFIGURED

can you post the output of this

su -
yum repolist all

that will list ALL repo files installed and there state ( on / off )

mansourk 01-26-2013 11:29 PM

Yes i've installed some third party repos. Here is the output of "yum repolist all":

Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
epel/metalink                                            | 4.4 kB    00:00   
 * base:
 * epel:
 * extras:
 * rpmforge:
 * updates:
base                                                    | 3.7 kB    00:00   
extras                                                  | 3.5 kB    00:00   
rpmforge                                                | 1.9 kB    00:00   
updates                                                  | 3.5 kB    00:00   
repo id                repo name                                  status
C6.0-base              CentOS-6.0 - Base                          disabled
C6.0-centosplus        CentOS-6.0 - CentOSPlus                    disabled
C6.0-contrib          CentOS-6.0 - Contrib                      disabled
C6.0-extras            CentOS-6.0 - Extras                        disabled
C6.0-updates          CentOS-6.0 - Updates                      disabled
C6.1-base              CentOS-6.1 - Base                          disabled
C6.1-centosplus        CentOS-6.1 - CentOSPlus                    disabled
C6.1-contrib          CentOS-6.1 - Contrib                      disabled
C6.1-extras            CentOS-6.1 - Extras                        disabled
C6.1-updates          CentOS-6.1 - Updates                      disabled
C6.2-base              CentOS-6.2 - Base                          disabled
C6.2-centosplus        CentOS-6.2 - CentOSPlus                    disabled
C6.2-contrib          CentOS-6.2 - Contrib                      disabled
C6.2-extras            CentOS-6.2 - Extras                        disabled
C6.2-updates          CentOS-6.2 - Updates                      disabled
base                  CentOS-6 - Base                            enabled: 6,346
c6-media              CentOS-6 - Media                          disabled
centosplus            CentOS-6 - Plus                            disabled
contrib                CentOS-6 - Contrib                        disabled
debug                  CentOS-6 - Debuginfo                      disabled
epel                  Extra Packages for Enterprise Linux 6 - x8 enabled: 8,326
epel-debuginfo        Extra Packages for Enterprise Linux 6 - x8 disabled
epel-source            Extra Packages for Enterprise Linux 6 - x8 disabled
epel-testing          Extra Packages for Enterprise Linux 6 - Te disabled
epel-testing-debuginfo Extra Packages for Enterprise Linux 6 - Te disabled
epel-testing-source    Extra Packages for Enterprise Linux 6 - Te disabled
extras                CentOS-6 - Extras                          enabled:    17
google-chrome          google-chrome - 64-bit                    disabled
remi                  Les RPM de remi pour Enterprise Linux 6 -  disabled
remi-test              Les RPM de remi en test pour Enterprise Li disabled
rpmforge              RHEL 6 - - dag                enabled: 4,458
rpmforge-extras        RHEL 6 - - extras            disabled
rpmforge-testing      RHEL 6 - - testing            disabled
tor                    Tor experimental repo                      disabled
tor-source            Tor experimental source repo              disabled
updates                CentOS-6 - Updates                        enabled: 1,092
repolist: 20,239

John VV 01-27-2013 12:11 AM

no wonder you are having problems
you still have cent 0 & 1 & 2 repo files present, disabled but still in the yum.repo.d folder

CentOS 6.3 is the current

base CentOS-6 - Base enabled: 6,346 -- GOOD
updates CentOS-6 - Updates enabled: 1,092 -- GOOD
epel Extra Packages for Enterprise Linux 6 - x8 enabled: 8,326 -- might need yum-priorities installed
rpmforge RHEL 6 - - dag enabled: 4,458 -- NEEDS yum-priorities installed
rpmforge is causing some problems most likely

though RPMforge has gone to great length to get compatible with the base and updates repos , it still can change some BASE system files over to rpmforge . When that happens the base abd updates and epel become incompatible

the issue IS a lot better that it was/ is in centos5 but it is still there .

remi also will cause problems when mixed in with ( rpmforge & epel )

Suggest caution if using this repo due to replacement of core packages.

the "seg faults" are a common issue with missed matched rpm's installed from incompatible repos

depending on just what was installed from where and how many packages ( and what they are ) it ? might ? be fixable
-- no guaranties !!! ---

i would first start with uninstalling every rpmforge rpm

su -
rpm -qa | grep rf

will output a list from RPMforge
then disable the rpmforge repo
( in the case of system files replaced with rpm's from the updates and base )
then uninstall all "rf" rpm's

then run " yum update"
using ONLY the base and update repos

-- no guaranties !!! ---

if that works and you still have a working system ( you might NOT )
install the yum plugin and configure it

then do the same for remi
SEE: the warning on the centos wiki

Suggest caution if using this repo due to replacement of core packages.

then add back in ( guessing multimedia rpms ) the programs from rpmforge
-- with yum-priorities running , that will stop base system programs from being replaced

--- note ---

It might be much faster to do a new clean install of centos 6.3 from the dvd
if you have a good back up of your data than trying to fix it

if only a few ,say12 or so, base packages were replaced it is fixable
might take a day or 3 ...

mansourk 01-27-2013 08:50 AM

Thank you, John, for your complete reply. Looks like i've screwed up things quite badly. I reckon i'd go for a clean install since it'd save me some headaches, but this time i'd be much more cautious with third party repos. Thanks everybody for kind replies, i learned a good deal from you.

mansourk 02-01-2013 07:47 AM

Finally i found the cause of that issue. As John suggested it was a problem of incompatible rpms, and it was
caused by installing "zlib" package from source while an older version of it was already installed on my system.
I found this after making a fresh CentOS 6.3 installation, and getting the same issues after i installed a bunch of
scientific packages from source.

John VV 02-01-2013 02:06 PM


I found this after making a fresh CentOS 6.3 installation, and getting the same issues after i installed a bunch of
scientific packages from source.
if you neet newer versions of some programs you can build the source
BUY do not !!! install it to /usr !!!!

instead use a build folder
like the install folder for the program that NEEDS a newer version of the program as a prerequisite, and do NOT put that folder in the system $PATH

for example

the development gimp 2.9

make a folder called /opt/gimp2.9

on cent this would need EVERYTHING and EVERY prerequisite built

---To use just one as an example ----

the current testing gtk

pass "/opt/gipm2.9/gtk as the "--prefix=" install location in building gkt
then pass that build folder to gimp for
and others to the build line

this is where a build script can come in handy to run configure and make

for more than one or two dependencies it becomes very complex


i installed a bunch of
scientific packages from source.
what ones , i might be able to help if i knew what they were ?

some might be in third party repos

mansourk 02-01-2013 11:39 PM

Thank you, John. I uninstaled the zlib package which i had installed from source and for now everything seems
to work alright, I had installed it in /usr/local and it was screwing with my system. I have also installed "szip"
and "HDF5" in /usr/local which for now havn't caused any problems. Thanks for the instructions, it's extremely usefull for me because i get to install many packages from source.

John VV 02-02-2013 12:23 AM

i tend to build from source a lot of things
some just because i have been building them for 10 years and it is a " no brainer" to do

BUT if one of the prerequisites needs something newer ( or older ) than is in the system
the operating system must not see it or at least see it AFTER the version that is default

This can lead to some odd problems if one makes a "oops" and installs a conflicting program like say "glib"
the Gimp example i used often needs a newer version than even the current fedora might have

In your case it was zlib so not to much damage and it was in /usr/local

it takes time to learn the "ins and outs" so just make sure you do learn from the mistakes , then learn from the all new, new ones you WILL make .

All times are GMT -5. The time now is 06:47 AM.