-   Red Hat (
-   -   problem installing glibc-2.11 (

aleppos 12-05-2009 04:32 PM

problem installing glibc-2.11

i try install "glibc-2.11" but i get this message

Use of uninitialized value in string ne at scripts/ line 164, <LDD> line 19.
Library libgcc_s is not correctly installed.
Please check your installation!
Offending line of ldd output: => /lib64/ (0x00002b510e3c3000)

The script has found some problems with your installation!
Please read the FAQ and the README file and check the following:
- Did you change the gcc specs file (necessary after upgrading from
Linux libc5)?
- Are there any symbolic links of the form to old libraries?
Links like -> (where is an old library) are wrong, should point to the newly installed glibc file - and there should be
only one such link (check e.g. /lib and /usr/lib)
You should restart this script from your build directory after you've
fixed all problems!
Btw. the script doesn't work if you're installing GNU libc not as your
primary library!

so i make this:
add this line
next if ($name eq "gcc_s");
before this line
$found{$name} = 1;
in this file "scripts/"
and i run this file "./scripts/" without "make install" to ckeck it and i get this resullt "Your new glibc installation seems to be ok."

but before i try "make install" again i open this ticket
to see if this is right or wrong, but it's wrong

after i upgrade GCC to 4.4.2 i get this problem
gcc: error while loading shared libraries: cannot open shared object file: No such file or directory

so i make this
ln -svf /usr/lib/gcc/x86_64-redhat-linux/lib64/ /lib64/
ln -svf /lib64/ /lib64/
to gcc work fine but i don't know if this is right or worng

Configured with: ../gcc-4.4.2/configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --disable-multilib --enable-clocale=gnu --enable-threads=posix --disable-nls --enable-checking=release --with-system-zlib --with-gnu-as --with-gnu-ld --with-newlib --verbose --with-system-zlib --enable-version-specific-runtime-libs --enable-__cxa_atexit --disable-libunwind-exceptions --enable-libgcj-multifile --enable-libada --enable-libssp --enable-languages=c,c++,objc,obj-c++,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/java/jdk --with-cpu=generic --enable-libgcj --build=x86_64-redhat-linux
Thread model: posix
gcc version 4.4.2 (GCC)

ldd /usr/bin/gcc => /lib64/ (0x00002b37095be000) => /lib64/ (0x00002b37097d3000)
/lib64/ (0x00002b370939e000)

please help me .

knudfl 12-05-2009 07:12 PM
"Building glibc is quite tricky and has a number of pitfalls....
Never install over a live system. ..."

( Will immidately trash the OS. For ever.)

Are you still using Redhat 9 ? ?
... No applicatons need glibc-2.11 ...

If you want a glibc-2.11, then install Redhat Fedora 12,
.. where it is already included.
So there are twelwe releases between Redhat 9 and today.
Redhat 9 was declared dead and unsupported five years ago.

Instructions for building a new OS from scratch with glibc-2.11
..... .. :) ..

aleppos 12-05-2009 11:39 PM

i need glibc to build java and when i try build java i get this problem
error while loading shared libraries: cannot open shared object file: No such file or directory

and that's mean my installation is incomplete cuz i get this message
Offending line of ldd output: => /lib64/ (0x00002b510e3c3000)

i figured my problem in libgcc_s cuz after i upgrade gcc and look for ldd /usr/bin/gcc => /lib64/ (0x00002b37095be000) => /lib64/ (0x00002b37097d3000)
/lib64/ (0x00002b370939e000)

i don't know why it appears in ldd ?

i need help cuz i build glibc over live system and it's too dangerous

knudfl 12-06-2009 06:24 AM

Glibc is already installed. No glibc = No OS.
Glibc is your system ( together with the kernel.)

Please open the terminal :
The command 'ls /lib/'
..will show that it is already present.

You may be missing the ' -devel ' packages :

They are on your install cd , disk 1.
Install these, and you have all 'glibc' installed.

aleppos 12-06-2009 06:45 AM

yes i have glibc but installation not complete

root@server [~]# ll /lib64/libc.*
lrwxrwxrwx 1 root root 12 2009-11-12 15:56 /lib64/ ->*
root@server [~]# ll /usr/lib64/libc.*
-rw-r--r-- 1 root root 20763228 2009-11-12 18:20 /usr/lib64/libc.a
-rw-r--r-- 1 root root 253 2009-11-12 18:20 /usr/lib64/
root@server [~]# ll /lib64/
-rwxr-xr-x 1 root root 8495189 2009-11-12 17:13 /lib64/*

knudfl 12-06-2009 07:15 AM

Looks like a Fedora 12 , x86_64 .

Is that what it is ? ?

Please tell, which Linux you are using, every time
a question is asked !
Like Fedora 12, x86_64

aleppos 12-06-2009 07:44 AM

root@server [~]# uname --all
Linux server 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

knudfl 12-06-2009 08:08 AM

2.6.18-164.el5 :
The OS name is "CentOS 5.4", "SL54" or "Redhat EL 5". ?

So how did those "Fedora 12" files got installed into your OS ?
( ).

Usually one would just do ..
# yum install glibc-devel glibc-headers
.. to have it all.


aleppos 12-06-2009 08:22 AM

CENTOS 5.3 x86_64 standard on server


but i don't like use yum or rpm is there some way to fix it ?

if my gcc not load libgcc_s i think my problem will solved but i don't know how,

i find this thread but i don't know is this right or wrong ?

Originally Posted by bean66 (Post 3200612)
On aix 5.3 using gcc version 4.2.4 I get the following output from ldd.
What causes libgcc_s.a to be part of the binary?

Or better, how can i prevent libgcc_s.a to be part of the binary? I've tried rebuilding gcc using configure -disable-shared to no avail.


ajax:ajax102:/home/n/ix_/src/server>> ldd 102/ixp_server
102/ixp_server needs:


Originally Posted by bean66 (Post 3201924)

I figured the problem out and thought I'd post my resolution so maybe it will help others.

rebuild GCC using -disable-shared.
Rebuild all libraries that were being linked that were built with the old version of gcc.

cuz if i rebuild gcc using -disable-shared and that's was not right my OS will destroy .

DrLove73 12-06-2009 01:01 PM

CentOS 5.x with upgraded glibc will no longer be CentOS, so just install Fedora 12 or stick with glibs released with CentOS. DO NOT MIX!!!

aleppos 12-06-2009 01:51 PM

i can't install Fedora 12 cuz i'm using it my OS , so please give me another solution.

about libgcc_s any one know how to fix it ?

knudfl 12-07-2009 01:25 PM

There isn't much you can do to repair.
Except a reinstall of the OS.

CentOS 5.4 is equipped with three gcc compilers,
which all can be there at the same time, to be used
for different jobs ...
gcc (4.1.2) : The system compiler, not to be changed.
gcc44 4.4.x : to be installed with yum.
compat-gcc-34 , 3.4.6 , also installable with yum.
No need trying to build another gcc-4.4.x, which
will probably not pass all tests in the test suite.
And thus not be very usable. Cannot build a glibc.

It is OK to have an extra glibc, but it must be very
well hidden away, for no files to find it.
But I see no reason for a glibc-2.11 in CentOS.

John VV 12-07-2009 06:07 PM

a new version of glib ( and EVERY DEPENDENCY) can be installed BUT it is VERY VERY VERY difficult !!!!!!!

first it AND every dependency MUST NOT BE IN THE SYSTEM PATH
build EVERYTHING in it's own build directory ( and DO NOT ADD THAT FOLDER to the $PATH - - do not- do not )

then pass that folder to the program you are building
as a build option in configure or as a environment variable using "export" before building

i have needed to do this for the dev./testing version of "the Gimp" when it needs a newer version of gtk or autotools or packageconfig . than the OS is using

it is A VERY BIG PAIN IN THE A$$ to do but it is possible

lazlow 12-07-2009 07:19 PM

And if you are even seriously think about doing it, have a very good backup system. One little mistake and the OS is done.

John VV 12-07-2009 10:00 PM


And if you are even seriously think about doing it, have a very good backup system. One little mistake and the OS is done.
a simple typo in a terminal option or forgetting to add lines to a config file or a mistake in a hand wrote/edited makefile and you HAVE KILLED THE OPERATING SYSTEM !!!!!

and a full reinstall might be needed to fix it .

this is VERY easy to do , yes i have done it once and only once
triple check command BEFORE you run it

when i build newer versions of code i install them on A DIFFERENT partition or drive that the os is on
that way there is less of a chance of a "R.I.P." / FUBAR mistake

but make sure you have a up to date back up

All times are GMT -5. The time now is 03:42 AM.