LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 05-20-2009, 10:55 AM   #1
manimal29
LQ Newbie
 
Registered: Jun 2008
Posts: 11

Rep: Reputation: 0
Problem downing wlan0 and powering down the box


I have managed to configure a wireles PCI card on CentOS 5.3 and it seems to work fine.
It is a off brand (Hercules) with a Ralink RT61 chipset. I installed the most current driver (RT2501PCI/mPCI/CB(RT61:RT2561/RT2561S/RT2661) from the rt2x00 Open Source Project. I now have a question that might be very simple for one or more of you to answer. When I issue the command "shutdown -h now", the machine starts to come down and brings down eth0 cleanly, but when it attempts to bring down wlan0, the machine hangs and never brings down the interface OR powers off the box. The only way to complete the power off is to "hard" power off the machine. Any ideas? Thanks for all the help!
 
Old 06-08-2009, 10:13 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,409
Blog Entries: 55

Rep: Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582Reputation: 3582
No idea. Nothing in syslog about it? Could try to do the reverse of how you would bring up your wireless manually and then shutdown. If that works you could add it to the shutdown part of your network initscript.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Forwarding my wlan0 to etho on my ubuntu box satiober Linux - Newbie 1 04-29-2009 03:54 AM
Problem powering on virtual machine in Vmware 6.5.1 accordeoniste Linux - Software 0 02-26-2009 02:22 PM
trouble powering up box, bad mobo? justwantin Linux - Hardware 6 02-03-2008 01:06 PM
New Box Build Not Powering Up... GNewbie Linux - Newbie 1 03-04-2007 01:49 AM
Powering off when powering off, how hard can it be? Ian_Hawdon Slackware 14 01-19-2006 03:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 03:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration