-   Red Hat (
-   -   port 25 connection refused even from localhost?? (

Ed1952 11-13-2005 10:52 AM

port 25 connection refused even from localhost??
I am trying to set up a sendmail server on a RH Enterprise Workstation computer. I got a web server, and other stuff up and running, but I cannot get the e-mail server to work. For a while, I could send e-mail directly from the machine, but not from another machine on my network with Eudora, but now I cannot send or receive from the machine. I've tried making all sorts of changes to according to different posts that I have found, and I've looked at (and even turned off iptables), but there was nothing in it restricting anything. I've turned off all firewall stuff on the machine, and also on my internal firewall/router/gateway/dhcp server. But, I can't even telnet to port 25. I get connection refused, even when I sit at the machine, open a terminal window, and type telnet 25 I get connection refused!! I also tried coming in through my firewall from outside my private network, and get the same result. I've also tried telnetting into the ip address from other machines on my private network. Still refused. I've also used the machine name and domain name. Still refused.

If I type netstat -an, I get a whole bunch of stuff, and I can see that clearly a bunch of ports are turned on and connected to, BUT NOT port 25 Any ideas what the problem can be? I've even tried typing various commands that should open up the port, under iptables, but nothing works.

sigsegv 11-14-2005 08:30 PM

At the risk of stating the obvious, are you sure sendmail's running? Try service sendmail status and I'm guessing you'll need a service sendmail start after that.

Ed1952 11-15-2005 08:24 AM

Yes, it is running. When I give the command service sendmail status, it reports that sendmail is running. One thing that is strange is that it takes a long time to start or restart sendmail. Something like a minute or more, while all other services start or restart in a matter of less than a second. Also, I keep getting a message sent an invalid ICMP type 11, code 0 error to a broadcast: Also, I note that sm-client is not running, and it fails when the machine boots. I can telnet into other ports that I am trying use use, like 110, without any problem. It is only port 25 that is blocked, and this is even on the machine, itself, from the console, or from another machine on my private network.

All times are GMT -5. The time now is 03:06 AM.