LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 11-14-2003, 09:18 PM   #1
Rowsdower11
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Rep: Reputation: 0
Unhappy out of range...


well, i already posted this in the hardware forums, but someone told me that i might get some better answers in here. First of all, im trying to use redhat9, and im dual booting with windows xp, using LILO. When i try to run xwin, i get an "out of range" error from my monitor (which is an LCD, pretty much noname brand). The monitor tells me that linux is trying to use some completely insane vert and horiz refresh rates that are way lower than the ones i specified in XF86Config. I have a Nvidia Geforce FX 5600 (256mb), i doubt its a video card problem though, since im using VESA video drivers. I went through XF86Config pretty carefully, i set the correct horiz and vert refresh rates, and i even tried disabling ddc, hoping that maybe that was the source of my problem. Im pretty much a noob with linux, so i cant think of anything else i can try to do.
 
Old 11-15-2003, 12:18 AM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
I am not in front of my RH box, so this is from memory. If you use Xconfigurator to setup XF86Config-4 (save your old file first), my recollection is that when you choose your monitor from the supplied list that if you go down the list to Generic... there are some laptop or flat screen choices. Try choosing the entry there that matches your LCD's resolution.
 
Old 11-15-2003, 02:12 PM   #3
Rowsdower11
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Original Poster
Rep: Reputation: 0
well i tried choosing a laptop lcd, but i get the exact same problem... The change doesnt seem to appear in XF86Config.

btw...im pretty sure RH9 doesnt use an XF86Config-4

Last edited by Rowsdower11; 11-15-2003 at 02:13 PM.
 
Old 11-15-2003, 09:57 PM   #4
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
The XF86Config-4 file was introduced as part of XFree86 4.0. My recollection is that XFree86 will default to XF86Config-4 first, and if it does not exist it will use XF86Config. Perhaps you have been tweaking the wrong config file?
 
Old 11-16-2003, 11:08 AM   #5
Rowsdower11
LQ Newbie
 
Registered: Nov 2003
Posts: 7

Original Poster
Rep: Reputation: 0
i already checked for that, XF86Config-4 doesnt exist, and i think i read in some redhat documentation that rh9 doesnt use it any more.
 
Old 11-17-2003, 11:05 AM   #6
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
So, XF86Config-4 does not exist, and changes you select in Xconfigurator do not show up in XF86Config. Sounds like something is broken that it is hard to get a handle on.

You should probably heck your /var/log/XFree86.0.log file to make sure you are straight on which configuration file is being used.

Also, to make sure we are on the same page, you said you are starting X by running xwin. The only xwin program I am familiar with is to start X using Cygwin/XFree86 under MSWin. Under Linux, you use the program startx to start X.
 
Old 11-17-2003, 12:39 PM   #7
aqoliveira
Member
 
Registered: Dec 2001
Location: Portugal
Distribution: /Red Hat/Fedora/Solaris
Posts: 622

Rep: Reputation: 30
Howzit

Try using this cmd first redhat-config-xfree86 this will allow u to choose monitor / vga card and approriate settings. To choose generic settings try this cmd redhat-config-xfree86-nui this will place generic screen as well as vga settings for your system. I also noticed that u have a nvidia card try downloading the drivers installing them then try what I mentioned again. Remeber that u must be in text mode for this to work therefor either init 3 or change runlevel to 3 in /etc/inittab. Trust me when I say for u to get video drivers for your vga card.

Good Luck

chow
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
get ip range. bruse Linux - Wireless Networking 2 08-23-2005 07:37 AM
Out of range peterx1 Red Hat 1 09-17-2004 11:23 AM
Out of range Elyubarov Linux - Hardware 1 08-12-2004 08:49 PM
Frequency Range ViPeRDeSiGnZ Linux - Newbie 11 01-24-2004 12:23 PM
out of range... andy010 Red Hat 5 11-19-2003 07:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration