LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   no space left on device, but it has enough!!! help!!! (https://www.linuxquestions.org/questions/red-hat-31/no-space-left-on-device-but-it-has-enough-help-285690/)

sarah21 02-03-2005 05:24 AM

no space left on device, but it has enough!!! help!!!
 
I recover my RedHat3 U4 from ghost , but I cannot work on it. Who can help me? :(
-----------------------------------------------------------------------
Problems:
1) The grub appeared when I start the system, I have to reload the kernel and changed the grub.conf and fstab files.

My filesystem (used df -k):
Filesystem 1K-blocks Used Available Use% Mounted on
/dev/hda1 18381408 2656656 14803028 16% /
/dev/hda5 15323624 8481124 6842500 56% /mnt/win
none 509448 0 509448 0% /dev/shm

(used df -i):
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/hda1 415104 415104 0 100% /
/dev/hda5 0 0 0 - /mnt/win
none 127362 1 127361 1% /dev/shm


(used fdisk -l):
Disk /dev/hda: 37.4 GB, 37420377088 bytes
255 heads, 63 sectors/track, 4549 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 1 2295 18434556 83 Linux
/dev/hda2 2296 2638 2755147+ 82 Linux swap
/dev/hda3 2639 4550 15353602 f Win95 Ext'd (LBA)
Partition 3 does not end on cylinder boundary.
/dev/hda5 2639 4550 15353570+ c Win95 FAT32 (LBA)


Before I changed grub.conf:
default=0
timeout=10
splashimage=(hd0,1)/boot/grub/splash.xpm.gz
title Red Hat Enterprise Linux AS (2.4.21-27.EL)
root (hd0,1)
kernel /boot/vmlinuz-2.4.21-27.EL ro root=LABEL=/
initrd /boot/initrd-2.4.21-27.EL.img
title DOS
rootnoverify (hd0,4)
chainloader +1

After I changed grub.conf:
default=0
timeout=10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title Red Hat Enterprise Linux AS (2.4.21-27.EL)
root (hd0,0)
kernel /boot/vmlinuz-2.4.21-27.EL ro root=LABEL=/
initrd /boot/initrd-2.4.21-27.EL.img
title DOS
rootnoverify (hd0,4)
chainloader +1

Before I changed the fstab:
LABEL=/ / ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
/dev/hda5 /mnt/win vfat defaults 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda3 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,r
o 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

After I changed the fstab:
LABEL=/ / ext2 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
/dev/hda5 /mnt/win vfat defaults 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda2 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,r
o 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0


----------------------------------------------------------------------------------------------
2) When I unzip the tar files, it says "No space left on device". After I tried many times, the problem appeared even if I want to login the console with graphic interface.

bbk 02-03-2005 05:53 AM

as I can see, you have used up all of your inodes. It does not matter how much free space you have if there is no free I-node to allocate the file to.

(used df -i):
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/hda1 415104 415104 0 100% /

Check the man page of mke2fs:

"-i bytes-per-inode
Specify the bytes/inode ratio. mke2fs creates an inode for every bytes-per-inode bytes of space on the disk. The larger the bytes-per-inode ratio, the fewer inodes will be created. This value generally shouldn't be smaller than the blocksize of the filesystem, since then too many inodes will be made. Be warned that is not possible to expand the number of inodes on a filesystem after it is created, so be careful deciding the correct value for this parameter."

especially the Be warned section...

But first, check that why do you have 415 thousand files anyway? :-)

sarah21 02-03-2005 06:12 AM

Thanks very much , I will try this way!

sarah21 02-03-2005 09:37 PM

If I use "mke2fs -i", my data in my /dev/hda1 has been lost, I want to keep my data and increase the inodes number, How can I do this???


All times are GMT -5. The time now is 04:58 PM.