-   Red Hat (
-   -   no password configured for vnc auth (

sidra 03-25-2008 07:45 PM

no password configured for vnc auth

I've configured vnc to run for a user other than root. It's running but doesn't let me log in when i do so from vnc viewer. Gives the following error:

No Password Configured for VNC Auth

I changed the password using vncpasswd and restarted the vncserver. Using IP:Port to log on, no luck

This works for root however.

Please help.


gilead 03-25-2008 08:08 PM

What command line do you use to start the vncserver and do you run it as the user (and not as root)?

sidra 03-25-2008 08:15 PM

I run is as that user, not root! The following command:

/usr/bin/vncserver -geometery 1024x768

gilead 03-25-2008 08:37 PM

I also specify a display when I start the server (for example, vncserver :1 1024x768) and when I connect I use IP:display, not the port (for example vncviewer

That shouldn't cause a password error though, it would stop the connection if it were incorrect. Have you had a look in ~/.vnc/passwd to see if there is an obfuscated password string plus your username?

sidra 03-25-2008 08:57 PM

It works now, nevermind, the passwd file was empty so i just used vncpasswd again to populate it. Thanks!

All times are GMT -5. The time now is 03:27 PM.