-   Red Hat (
-   -   nm-applet icon missing (

Linux.Girl 08-19-2010 07:21 AM

nm-applet icon missing
Hello everyone,

I am completely new both here and in Linux. I carefully read the threads where you explain where to post what, and even searched for previous postings which might have already answered my question, unfortunately, I still got the problem.

Since my distro is CentOS 5.5, I decided to post here, hope it was the right decision (if not, please let me know where I should have posted).

So as the subject says, I installed CentOS and can't manage to make the nm-applet icon show on the notification area.

I read previous threads about this, which suggest that perhaps nm-applet is not running, or that perhaps I did not add a notification area to the panel, or that maybe nm-applet --sm-disable is not showing on sys-sessions. Unfortunately, all the above is ok, i.e, nm-applet is running, I do have a notification area and "nm-applet --sm-disable" appears as it should in the right place.

Do you have any other suggestions?

Many thanks in advance.


Linux.Girl 08-19-2010 04:50 PM

Hello, if I give more details maybe someone can help me? I tried to do a killall gnome-panel and then check .xsession-errors to see if I could get a clue of what is wrong. Of course, I took this tip from someone else and even more "of course", I did not understand the result. Here is what is said, maybe it will give the experts a clue as to why my nm-applet icon is not showing?

cat /home/me/.xsession-errors gives the following:

** (nm-applet:4319): WARNING **: No connections defined

** (nm-applet:4319): WARNING **: Invalid return value type: GPtrArray_DBusGObjectPath_
Introspect error: The name edu.duke.linux.yum was not provided by any .service files
Traceback (most recent call last):
File "/usr/bin/puplet", line 467, in ?
File "/usr/bin/puplet", line 464, in main
File "/usr/bin/puplet", line 451, in run
File "/usr/bin/puplet", line 191, in _refreshInfo
if self.updatesObject is not None and \
AttributeError: DBusException instance has no attribute '_dbus_error_name'

I don't know if this is related or not, can you please please help me?

Thanks in advance.


RockDoctor 08-19-2010 05:42 PM

When the nm-applet icon doesn't show, it means either nm-applet isn't running, or NetworkManager isn't running. Open a terminal window and enter

ps ax | grep nm-applet
to see if nm-applet is running, and

ps ax | grep NetworkManager
to see if NetworkManager is running. If Networkmanager isn't running, then, as root, run

I had a problem today in Fedora 14 alpha with nm-applet not showing up or running even though NetworkManager appeared to be running. My fix was to downgrade the versions of NetworkManager, NetworkManager-glib, and

Linux.Girl 08-20-2010 07:05 AM

WOW!!! it worked, can't believe it - so many thanks!!!

Now the weird thing is that both network manager and applet appeared as running, but it seems they weren't after all. After I did a start on /etc/init.d/NetworkManager the icon appeared!

[m@localhost ~]$ ps ax | grep nm-applet
3257 ? Ss 0:00 nm-applet --sm-disable
3584 pts/1 S+ 0:00 grep nm-applet

[me@localhost ~]$ ps ax | grep NetworkManager
3272 ? S 0:00 /usr/sbin/nm-system-settings --config /etc/NetworkManager/nm-system-settings.conf
3586 pts/1 R+ 0:00 grep NetworkManager

[me@localhost ~]$ su

[root@localhost me]# /etc/init.d/NetworkManager start
Setting network parameters... [ OK ]
Starting NetworkManager daemon: [ OK ]
[root@localhost me]#

Why would networkmanager and applet appear as running when actually they weren't?

RockDoctor 08-20-2010 03:57 PM


After I did a start on /etc/init.d/NetworkManager the icon appeared!
That is how it works for me (when working properly).

Are you saying that after you did the start on /etc/init.d/NetworkManager it wasn't actually working even though the nm-applet icon appeared?

DrLove73 08-20-2010 07:30 PM

Restart the system and check if nm-applet shows. If not, then you need to set NetworkManager to start on boot.

I have not checked, but it is possible that if NetworkManager service is not running nm-applet does not show icon.

Linux.Girl 08-21-2010 06:50 AM

Hi RockDoctor, thanks for your help - what you told me to do worked. I started networkmanager and the icon appeared. I was just puzzled because BEFORE I started networkmanager, it was showing itself as working and the icon was not there. The I hit restart (after your tip) and the icon appeared.

In any event, case solved, many thanks for the help!

@DrLove73 - how do I make sure networkmanager starts on boot?

Thanks in advance.


DrLove73 08-21-2010 10:51 AM

System -> Administration -> Server Settings -> Services
System -> Administration -> Services

and then make sure you tick NetworkManager ans Save settings.

Manually, you would run (as root):

chkconfig --level 2345 NetworkManager on

All times are GMT -5. The time now is 11:24 AM.