-   Red Hat (
-   -   Network Accounts Disabled? (

ComputerErik 05-26-2008 01:56 PM

Network Accounts Disabled?
I am setting up a Red Hat Enterprise Linux 5 workstation to play with a bit. I want to setup authentication against an existing Sever 2003 AD domain. I setup winbind, and joined the domain fine. Then when it comes to login I enter domain\username and hit enter, then enter the correct password. I then get an error that the administrator has disabled this account, but it isn't disabled in AD.

So I am guessing that in Red Hat somewhere there is something preventing a network based account from logging in. I have tried multiple accounts, and all get me the same error. What other steps do I need to take to get this working?

hob 05-27-2008 03:45 PM

It sounds like a configuration setting is missing or incorrect - there isn't a setting that stops accounts from logging in, but if you configure this by hand you have to edit a few different things. Red Hat supply a configuration tool to do the necessary setup for you, although I don't know how well it works.

If using the Red Hat tool doesn't solve the problem, post the text of the error, and a summary of how you've configured the system. This stuff is fiddly on Linux, and easy to get wrong :(

ComputerErik 05-29-2008 08:59 PM

Thanks, I think I got it figured out. I am now able to login authenticating with my NT account no problem.

I tried a bunch of different config setups, but in the end I am pretty sure the change(s) that got me up and running were pointing to my Windows server for NTP and also configuring SMB as an authentication method on Red Hat.

All times are GMT -5. The time now is 02:04 AM.