LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 10-13-2003, 05:32 PM   #1
drapaca
LQ Newbie
 
Registered: Oct 2003
Posts: 3

Rep: Reputation: 0
mpi++.h file missing in RH 9?


Hello;
I upgraded from RH7.2 to RH9 and everything looked O.K. till I tried to re-compile my VTK4.0. The error I get says that in the mpi.h file there is the following line #include <mpi++.h>
and it cannot find this mpi++.h file. I do know that this file existed in RH7.2 and even in RH8.0, but I don't know why it's not in RH9, even if it is still called in this mpi.h file. I tried to install an old version of the mpi++.h file taken from RH8, but the libraries are not correct anymore and hence I cannot compile vtk with the MPI turned on. I even tried to take out that mpi++.h stuff from the mpi.h file, but without any luck (I got other errors regarding other missing libraries). I don't know what else I can try. I don't think that this is a vtk problem, but a RH9 one (if this mpi++.h file is not in the RH9 anymore, than it should not ask for it in the mpi.h file!) If any of you have any idea about what else I can try, please let me know.
Thank you very much.
Corina
 
Old 10-13-2003, 10:27 PM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,084

Rep: Reputation: 54
From the lam package changelog:

Quote:
* Fri Dec 20 2002 Elliot Lee <sopwith@redhat.xxx> 2:6.5.8-1

- Update to new version in hopes of a fix for varargs problems
- Since it doesn't fix it, turn off mpi2c++ altogether - a package
that builds without C++ wrappers is preferable to a package that doesn't
build at all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mpi chui_yap Programming 1 03-07-2006 08:22 AM
what do I need to know to use MPI kgustaf Linux - Networking 0 07-25-2005 05:13 PM
mandrivia 10.1 and MPI 1.4 frodemt Mandriva 1 04-19-2005 01:57 PM
Yum update complains missing file (broken dep), but file can be located. davidas Linux - Software 0 03-27-2004 10:11 PM
mpi++.h missing in redhat9??? drapaca Linux - Software 2 10-10-2003 06:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 10:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration