LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   Mouse Problems with KVM (https://www.linuxquestions.org/questions/red-hat-31/mouse-problems-with-kvm-300107/)

moger 03-10-2005 03:19 PM

Mouse Problems with KVM
 
I just installed FC 3 and my mouse behaves fine unless I switch to my XP machine with my Belkin KVM switch and then come back to Fedora. My mouse then goes wild and I can't control it. I have a PS/2 2 button mouse with a scroll.

voiceofstopher 03-16-2005 08:59 AM

KVM Linux Mouse XF86Config Working Config
 
Getting Linux gui X mouse to work with a KVM: 8-port COMPAQ

1. I killed gpm process:
ps -ef | grep gpm #<gives process ID>
kill -9 [pid] #<kills that process>

2. Then changed my XF86Config file is as follows (excluding the snippet tags) [located at /etc/X11/XF86Config]:
<snippet>
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection
</snippet>

3. Then I did an
init 3 #<waited for it to cycle>
init 5

and voila, my mouse works with FreeX86 and my KVM

echlinm 05-27-2011 01:49 PM

same problem, solved
 
I have the same issue, a kvm, mouse goes crazy after switching screens.
I have a Microsoft intellemouse.
On Linux I changed the protocol to auto.
On the every time I switch to Linux the mouse goes crazy, so unplug the mouse from the kvm, pause, plug it back in. (The pause is required.)
No rebooting, the computer resets the mouse automatically when it gets plugged back in.

Try it tell me if it works for you.


All times are GMT -5. The time now is 02:13 PM.