-   Red Hat (
-   -   Mouse and Keyboard unresponsive after boot (RHEL 6) (

griffey 01-23-2012 04:29 PM

Mouse and Keyboard unresponsive after boot (RHEL 6)
Hi folks.

I have a system with a peculiar problem.

Once it has booted fully into runlevel 5 the mouse and keyboard are unresponsive (at login screen).

I press the caps lock key every now and then as the machine boots up just to make sure there is still some sort of signal from it, and it turns on and off as expected until X starts and then the keyboard and mouse both won't do anything and pressing caps lock no longer lights up when pressed, etc.

I booted into runlevel 1 and the keyboard worked fine. I set the default runlevel in /etc/inittab to 3 and the keyboard worked fine then as well. Hmm. Wonder if I can do startx when in runlevel 3...

startx will get X11 to start, and it spits a dozen lines of text to the screen right before the GUI starts up, and again, the mouse and keyboard are frozen. The textual messages appear and disappear too quickly for me to see what they are. This happens as root or a normal user.

The log file for Xorg has a date of today but is 0 bytes. The next older one is from September. (?)

Any ideas?

Thanks in advance!


John VV 01-23-2012 05:09 PM

have you searched the red hat knowledge base for this type of problem
you are paying for red hat so you might want to use there help
you will have to login to read the posts

is this a usb mouse & keyboard
a OLD parallel port mouse & keyboard ?
a wireless mouse & keyboard ?
or is this a laptop ?


Wonder if I can do startx when in runlevel 3
startx is not needed for rhel6 ( and by it's self might not work)
rhel6 uses GDM to start x and gnome
KDM to start x and KDE if that is used

saku192791128 03-30-2012 10:04 PM

# /etc/rc.d/init.d/haldaemon start
# /etc/rc.d/init.d/messagebus start
# startx

All times are GMT -5. The time now is 01:31 AM.