-   Red Hat (
-   -   Mounting fat32 drives with read/write access in Fedora (

a1ex_007 03-10-2005 08:29 AM

Mounting fat32 drives with read/write access in Fedora
How can i mount the drives in fat32 format so that users other than root can write on them
Anyone out there to help me out?

Andrew Benton 03-10-2005 08:37 AM

Yes, you need to put umask=0 on the line in /etc/fstab that mounts it, like so

/dev/hdb2 /mnt/share vfat umask=0 0 0

kovik89 03-23-2005 01:26 PM

Will this work with a external hard drive like the Maxtor One Touch?
I was able to use it up until yersterday when I was backing up some files when it gave me a message saying the destination is read I tried to change the permissions and it than says that I'm not the owner. I than tried from root but it repeats the same error messages. The Maxtor One Touch is a Fat32 external hard drive. Wierd how it all of a sudden denied me access. Any help would be appreciated, take care. Bob

p.s. How do you access the code to implement the changes?

Andrew Benton 03-23-2005 01:38 PM

Have you tried reformating the drive?

All times are GMT -5. The time now is 06:46 AM.