-   Red Hat (
-   -   mkinitrd results in: "No module aic7xxx found for kernel" (

jim_cliff11 12-21-2006 07:06 PM

mkinitrd results in: "No module aic7xxx found for kernel"
Hi guys,

Im trying to upgrade to kernel 2.6.18-1 on my server, however im having problems.

The server has a raid 0 setup on it and im sure this might be effecting my kernel instllation. Currently installed is the standard 2.4 kernel which runs fine with no problems.


Once ive made and configured the kernel and copied it to the /boot directory with i then use the command "mkinitrd /boot/initrd-2.6.18-1.img". When ever i try this command i get the following message appear "No module aic7xxx found for kernel".

Ive done abit of research and found alot of people have said compile the FS, SCSI and RAID modules into the kernel that way you wont need the initial ramdisk.

So i started again and compiled all the support for my hardware inc the above into the kernel itself so i dont need a ramdisk. Then i used the "make" command followed by "make modules". Copied the kernel and to boot, then used "make modules_install" command and finally added the new kernel to the menu.lst which looks like:

title Red Hat Linux (2.6.18-1)
root (hd0,0)
kernel /bzImage-2.6.18-1 ro root=LABEL=/
title Red Hat Linux (2.4.20-8smp)
root (hd0,0)
kernel /vmlinuz-2.4.20-8smp ro root=LABEL=/
initrd /initrd-2.4.20-8smp.img
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
initrd /initrd-2.4.20-8.img

Now when reboot from the 2.6 kernel i get a kernel panic:

"kernel panic - not syncing : VFS: unable to mount root FS on unknown-block (0,0)"

Im unsure of what to do to fix this, ive tried recompiling the kernel a few times and starting from scratch. If i use modules for the scsi and try to make an initrd i get the No module aic7xxx error. Whereas if i compile everything into the kernel i get the kernel panic.

What is causing this problem as i didnt have it before when upgrading my other machine to 2.6.18-1?

How can i get round the problems and install the kernel successfully?

Any help appriciated!



Ps. The server has a dual CPU setup running, would i need a special kernel especially for running 2 CPU's? Could this effect it?

Lenard 12-22-2006 03:00 PM

It takes a lot more then building a new 2.6 kernel you also have to install and upgrade some packages. Here are a couple of old links to guide you along this process;

And yes you need to run an smp kernel to use both CPU's, the configuration of the kernel should allow for this.

jim_cliff11 12-25-2006 12:01 PM

Thanks for the help mate,

However i already have all of the stuff installed and up to date.

I tried compiling kernel 2.6.19-1 the other day but im still getting the following error when trying to create the ram disk:

"No module aic7xxx found for kernel"

Can anyone tells me what causes this error and how i can get around it?


jim_cliff11 12-25-2006 08:45 PM


Ok all, i managed to get a ram disk created by copying the aic7xxx.ko module to aic7xxx.o and ips.ko to ips.o. I then ran the normal mkinitrd command and it was made. However after rebooting i got a "Module insmod: QM_MODULES: ERROR /bin/insmod exited abnormally!" error message.

Then i did a few more hours research and realised that i needed the new modutils which dosnt actually exist anymore and has been replaced by a new package called module-init-tools. So i downloaded the latest version of that and installed it.

I then remade the ram disk and rebooted only to be greeted with "insmod: error inserting '/lib/aic7xxx.o': -1 unknown symbol in module" and the same error for ips.o.

After all these errors the same kernel panic appeared on boot saying that VFS root could not be loaded or something, i cant remember quite how it went now.

I cant understand why the modules wont load on startup even with updating to module-init-tools. Im really stuck and unfortunatly im back to square 1! :(

I would really appriciate anyone who could help me out with this.

Thanks in advance.


Lenard 12-26-2006 08:30 AM

You really should consider upgrading the OS instead of attempting to build a 2.6 kernel for a large number of reasons. The renaming kernel modules is not an acceptable way to fix the booting problem, it does not work. You are in need of additional packages to build a kernel like udev and other packages.

Please review the ~/linux-<version number>/Documentation/Changes file for the requirements to build the kernel and this link;

To build a kernel for the Red Hat family the steps in order are, yes this does differ from the kernel rebuild guide(the link above) but they work rather well;

make mrproper
make menuconfig
make modules_install
make install

Spend the time required while using the 'make menuconfig' command to configure the kernel to meet your hardware requirements, the default configuration will not work and using an old 2.4 configuration will not work either (far to many changes in the kernel series for this to work). You might want to use 'make oldconfig' before the 'make menuconfig' command to get you started in the configuration.

FYI: you have prebuilt Red Hat Linux 9 kernels judging by;


title Red Hat Linux (2.4.20-8smp)
root (hd0,0)
kernel /vmlinuz-2.4.20-8smp ro root=LABEL=/
initrd /initrd-2.4.20-8smp.img
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/
initrd /initrd-2.4.20-8.img
Which are not really standard kernels except for Red Hat Linux 9.

Good Luck

jim_cliff11 12-26-2006 06:29 PM

Thanks for the advice mate.

Can u tell me more about changing the OS?
Do u mean scrap red hat and more to another distro?

What distro would u recommend using thats easier to compile 2.6? And is generly better than rathat.

What are the advantages of changing to a diff os than upgrading the kernel on red hat.

Or do u mean scrap linux altogether? If so i dont want to use Microsoft. Want to stay with unix or linux.

Or would i be best staying with a 2.4 kernel?

Thanks for the help.


Lenard 12-27-2006 08:58 AM

No, I am not suggesting you scrap Linux just the defunct Red Hat Linux 9. Nobody supports it any longer and Red hat ended support over three years ago.

If staying with the Red Hat family, fedora Core is the replacement series for the old Red hat Linux series. CentOS, Scientific Linux and others are freely available 100% binary compatible 'clones' of the Red Hat Enterprise Linux series.

All the latest versions are 2.6 kernel based, Fedora Core 5/6 is 2.6.18 kernel based while CentOS and SL are currently 2.6.9 based. Red Hat will be releasing RHEL5 shortly which is based on the 2.6.18 kernel and the work done on FC6/7 and the 'clones' will have releases shorty afterwards. Support for the RHEL series is in years while support for the Fedora Core series is in months (18-24).

If you want to stay with the 2.4 kernel series and have support available then look at CentOS, SL or the other 'RHEL3 clones' that are available.

jim_cliff11 12-28-2006 05:40 PM

Thanks for the advice and help Lenard.

I downloaded and installed Fedora 6, however i am having very strange problems with that now :( Its driving my crazy.

My Fedora thread is viewable at:

All times are GMT -5. The time now is 10:10 AM.