-   Red Hat (
-   -   mkinitrd failed with message "no module raid0 found for kernel 2.6.9" (

ythevenot 12-03-2004 07:27 AM

mkinitrd failed with message "no module raid0 found for kernel 2.6.9"
Hi all,

I've just installed Redhat 9.0 with raid (raid 1 for /boot partition and raid 5 for other partitions).
Now i'm trying to install the latest kernel: 2.6.9. I compiled it without any problem.
However when i tried to run mkinitrd, i received the following error message:
No module raid0 found for kernel 2.6.9...

I've tried to search for info about this problem, have found that such a bug was reported but doesn't seem to have a fix yet.
I've found a patch on another forum (ie:
I was a bit reluctant to install this patch coming from i don't know where, but with no other solution and reading that the user accepted this answer i gave it a try... however the patching file is not correct:
patch: **** malformed patch at line 4: modName="sbp2"

So i'm stuck here,
anybody has any advice?

What can i try?

Thanks in advance for comments/advices...

Kind regards,

dfowensby 12-04-2004 08:36 PM

i hope this doesnt sound ignorant, but you DO have modutils 3.0 or better compiled into your os, i hope. download and compile, if not.
and ensure all your raid options are set to Y before you bzImage etc...i had fits before i discovered setting most 2.5+ kernel options to Y was mandatory.
luck -O.

ythevenot 12-07-2004 08:56 PM

No it doesn't sound ignorant at all...

Regarding modutils, except if it comes with default Red Hat 9, i guess i don't have it.
Now, i haven't seen any version 3.0 on did u mean 2.3.0 ? if not any idea where i can find the 3.0 one? (i've only seen a reference to 3.0 version on buffalo distribution website...).

I'll also check the raid options in my kernel.

Thanks for your help,


ythevenot 12-07-2004 10:15 PM

According to the software requirement for 2.6.x kernels modutils is not needed anymore...

i just tried to re-compile with all the raid options included in the kernel, but still had the same error message when running mkinitrd...

My next try will be without raid... :(


All times are GMT -5. The time now is 04:52 AM.