LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 12-09-2004, 06:49 PM   #1
lbana
LQ Newbie
 
Registered: Dec 2004
Location: Melbourne
Distribution: Red Hat
Posts: 3

Rep: Reputation: 0
Angry Logout issue in FC3


Hi all,
I am having a problem with the login screen. I installed FC-3 and if restart computer I get the login screen and everything is fine. The problem comes when I do logout, this is causing to display in my monitor as "Is PC Settings Correct?" and dissapears with black screen.
I sincerely appreciate if you can help me on this issue or please provide pointers.
-Thanks
Laxman.
My xorg.conf file is shown below:
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "HP D5259A Pavilion M70 Monitor"
DisplaySize 320 240
HorizSync 31.5 - 71.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "r128"
VendorName "Videocard vendor"
BoardName "ATI Rage 128 Pro Ultra"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
 
Old 12-10-2004, 09:41 PM   #2
lbana
LQ Newbie
 
Registered: Dec 2004
Location: Melbourne
Distribution: Red Hat
Posts: 3

Original Poster
Rep: Reputation: 0
I found the problem...it was DRI. After commenting the DRI section and Load "dri" in xorg.conf the login screen appears after logging out. But still don't know why DRI causing black screen after logout and I was not able to do PING. This was a bit strange.
 
Old 12-10-2004, 10:38 PM   #3
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 77
I'm occasionally having this problem, I'll try your solution and see if it works for me.
 
Old 12-12-2004, 02:36 PM   #4
lbana
LQ Newbie
 
Registered: Dec 2004
Location: Melbourne
Distribution: Red Hat
Posts: 3

Original Poster
Rep: Reputation: 0
After running "up2date" for kernel, xorg, xdm I am able to add DRI features in xorg.conf and it works now. My kernel version is 2.6.9-1.681_FC3
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE logout issue a_priebe47 Slackware 19 02-04-2009 11:51 PM
FC3 Logout error 686plus Linux - Newbie 1 02-22-2005 06:17 PM
FC3 nvidia logout crash bwa Linux - Hardware 5 02-04-2005 10:55 PM
logout of gnome on fc3 MisterESauce Linux - Newbie 2 02-01-2005 01:27 AM
logout issue mufy LQ Suggestions & Feedback 4 01-10-2005 09:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 12:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration