LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   language switching in KDE (RH9) -- heeelp! (https://www.linuxquestions.org/questions/red-hat-31/language-switching-in-kde-rh9-heeelp-92514/)

LooseCanon 09-13-2003 08:51 PM

language switching in KDE (RH9) -- heeelp!
 
Oh boy... never thought I would be running into so much trouble - especially with Red Hat - with language keyboard options....

Please someone heeeelp me on this - its really important!!!

I switched from Gnome to KDE (don't like Gnome - too archaic ... don't know why Red Hat does everything Gnome either...) Anycase, I need quick access to three different languages on a regular basis - English, French and Russian.

In KDE, I switched on the "enable keyboard layouts" option in the Control Center and selected US as my primary language (with PC104 keyboard) and then selected FR and RU from the list. I notice there's a little widget that pops up in the panel at the bottom of the screen.

Well as soon as I try to write something, ALL input is in Russian, even though US is selected as the language. I switch to French and I can type with French characters (é, ç, _)... As soon as I swith back to English all I get is input in Russian!!! Fine, I go back to "enable keyboard layouts" and uncheck Russian and again try to type something using the US keyboard and ALL keyboard input is in Russian.
:scratch: :confused:

The only way I can get back to typing in English is if I log out and log back in.

Please if someone can help me I would really appreciate it!

LooseCanon 09-14-2003 06:26 PM

Has anyone else have this problem? or fixed a problem like this? Please help!

LooseCanon 09-22-2003 02:16 PM

well I've done a lot of research into this topic and I've only found other people with the same problem. I wrote Red Hat about this last week and I'm still waiting for an answer.

Language switching under Red Hat seems to be a disaster. :(

No problems at all thus far with SuSE, Mandrake, Debian.... Red Hat is the only one that's really messed up the language options. Sad to say for a good distro like this.


All times are GMT -5. The time now is 10:15 AM.