-   Red Hat (
-   -   Kernel update boot problems, no boot loader (

StaticSage 01-08-2004 04:15 PM

Kernel update boot problems, no boot loader
I've been toying with Red Hat 9 for a few days now. I've been searching around google and learned a little bit about kernel upgrades. After failing to upgrade successfully a few times, I re-clean installed and tried again. This time I found out about up2date, so I ran it and updated everything including the kernel files. Here's the problem:

I don't use a boot loader because I didn't feel comfortable playing with the master boot loader because I still use windows. With my luck I'd probably need to reinstall XP also. Anyway, I boot into Red Hat by using the bootdisk made during installation. I created a new bootdisk to go with the new kernel with

mkbootdisk 2.4.20-28.9
While attempting to boot with this disk I received an error that said something like, "Boot failed please insert another disk and press any key" while it was trying to load vmlinuz. I booted back with the old bootdisk to the old kernel and remade another bootdisk in case it was the disk. The other disk also failed with the same error.

Is there something I'm doing wrong? Any help would be greatly appreciated.

ac1980 01-08-2004 06:26 PM

I don't use mdk, so I don't know what the problem may be, however I have a suggestion: keep your old kernel disk as an emergency, and instead install either lilo or grub on the other floppy: this way you won't touch the mbr, but still you'll boot much faster. Grub can even be used as a standalone emergency disk to save unbootable pcs, while lilo is easier to setup but is specific to your disk, it has hard-coded file positions, so it has to be pdated anytime you change your kernel/partitions.

aqoliveira 01-09-2004 07:05 AM


not sure if u able to use the cmd the way u have being using it. It seems to me that u r creating a boot disk with the current kernel that is loaded. Try the following if donīt want to use boot loader. In your BIOS settings change it to boot from the linux drive instead of Windoze. Whenu need Windoze then change over again under BIOS.

Hope this helps


All times are GMT -5. The time now is 11:21 PM.