LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 04-29-2004, 07:30 PM   #1
podge_mcgee
LQ Newbie
 
Registered: Apr 2004
Location: Birmingham - England
Distribution: Redhat 9
Posts: 3

Rep: Reputation: 0
Kernel RPM missing module


Please could someone help me with the following problem as I am experienced with linux usage but a complete newbie when it comes to the kernel:

Upon trying to install the current RedHat.com kernel rpm (2.4.20-31.9) i get the following error:

No module iteraid found for kernel 2.4.20-31.9
mkinitrd failed
error: %post (kernel-2.4.20-31.9) scriptlet failed, exit status 1

Now I know why this is because I am running my linux drive off an ITE8121 ata controller so during install I had to provide a driver disk with the iteraid module on which I downloaded from the Gigabyte website.

My question is, is there anyway for me to add the module to the rpm or am I going to have to recompile the kernel (which I want to avoid if poss)?

Thanks in advance,
podge_mcgee
 
Old 05-01-2004, 10:58 AM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,084

Rep: Reputation: 54
How did you try to install the new kernel? Looks like you used rpm -Uvh instead of rpm -ivh and erased the previous kernel before the new kernel was installed fully.
 
Old 05-08-2004, 06:16 AM   #3
podge_mcgee
LQ Newbie
 
Registered: Apr 2004
Location: Birmingham - England
Distribution: Redhat 9
Posts: 3

Original Poster
Rep: Reputation: 0
Thans for the help, i worked out the problem, i got some newer drivers of the ITE website cuz the ITE drivers from the Gigabyte site were about 3 versions out of date.
Just had to recompile them for the new kernel and it worked.

Cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no kernel module build environment" Error message during RPM install gotmonkey Linux - Hardware 7 12-07-2007 03:08 AM
Missing 'module-info-2.6.12.2' after kernel compile. mr_mccabe Linux - General 1 07-14-2005 03:46 PM
alsa 1.0.7 rpm -F says snd_emu10k1 module is missing fight_the_$oft SUSE / openSUSE 0 11-23-2004 01:50 PM
missing kernel-ntfs-2.6.6-1.435.2.1.i686.rpm robgue Fedora 3 07-03-2004 01:11 AM
Cannot install e1000 module because of missing kernel source? schlagzeug Red Hat 5 11-07-2003 06:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 04:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration