-   Red Hat (
-   -   Installing RHEL 5.5 with partitions larger than 2.2 TB (

staticd 11-23-2010 06:12 PM

Installing RHEL 5.5 with partitions larger than 2.2 TB
Okay, so I am so happy to have my huge server (non-EFI) with six 2TB drives in RAID 6. Awesome.

I go to load RHEL 5.5 and I get this error after I set up my partitions:

"Your boot partition is on a disk using GPT partitioning scheme but this machine can not boot using GPT..."

Okay, okay.

So, I went and exited to the prompt and ran: `fdisk -l'

Sure enough I showed one boot device with a system ID of: `EFI GPT'


So I ran fdisk on the device and changed the ID to: `Linux' or `83' was the code

That didn't work either.

I then went back in and figured that I could regroup my large installs by just making 2.2 TB partitions as logical volumes and then adding them up after a successful install.

That didn't work either.

When I run parted, the disk isn't even recognized.

That didn't work either.

I have done quite a bit of searching but I have not found anything good, so I ask you fine folks for some help.

In the end, I want to have several small partitions (i.e. `/','/usr', etc.) and two really big partitions (like, whatever is left).

Alexvader 11-23-2010 06:24 PM

I think you can fix this if you run dd if=/dev/urandom of=/dev/sd... over that disk... use a Live medium... that will wipe out this EFI GPT thing... after that, i think this will allow you to install RHEL 5.5...

Just a guess tho... :)

syg00 11-23-2010 10:08 PM

It's complaining about the device, not partition(s). "the disk" implies a single device - is this hardware RAID ?. If so, can you adjust the properties/geometry of the device(s) exported ?.
I'm surprised parted won't talk talk it - what version ? For gpt disks fdisk will probably be misleading - what does "fdisk -l" (as root) give ? You'll need gdisk for gpt.

fcfury 12-01-2010 10:37 AM

Now correct me if I am wrong but doesn't Red Hat have issues seeing anything over 2 TB???

All times are GMT -5. The time now is 03:50 PM.