-   Red Hat (
-   -   Installing fontconfig 2.2.0 error (

tfdml37 03-27-2004 06:12 PM

Installing fontconfig 2.2.0 error
Trying to install fontconfig 2.2.0 so I can update pango. I just installed glib 2.4.0, atk 1.6.0 and freetype2 (all from source, yum and I cant find any up to date rpms). All this so I can update gtk so I can install ... oh who cares, god it's a mess. Anyway I get this error when I do make for fontconfig:

In file included from ../fontconfig/fcfreetype.h:27,
from ../src/fcint.h:39,
from fc-lang.c:25:
/usr/local/include/freetype2/freetype/freetype.h:20:2: #error "`ft2build.h' hasn't been included yet!"
/usr/local/include/freetype2/freetype/freetype.h:21:2: #error "Please always use macros to include FreeType header files."
/usr/local/include/freetype2/freetype/freetype.h:22:2: #error "Example:"
/usr/local/include/freetype2/freetype/freetype.h:23:2: #error " #include <ft2build.h>"
/usr/local/include/freetype2/freetype/freetype.h:24:2: #error " #include FT_FREETYPE_H"
make[2]: *** [fc-lang.o] Error 1
make[2]: Leaving directory `/home/user/fontconfig-2.2.0/fc-lang'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/user/fontconfig-2.2.0'
make: *** [all-recursive-am] Error 2

Any help would be extremely appreciated.

Andrew Benton 03-28-2004 07:32 AM

Glib-2.4 is the new series of Glib, so is atk-1.6. I don't know of anything that requires them. All the current apps use atk-1.4 and glib-2.2, the old stable branches.
But that's irrelevant to your problem, fontconfig doesn't depend on either of them. As far as I know it only depends on freetype (freetype-2.1.5 would be a good choice) and expat (1.95.7 is the current stable version I believe). Which versions of expat and freetype have you installed and what options did you pass to ./configure?

tfdml37 03-28-2004 08:56 PM

I had glib 1.2.9 (or there abouts, it's now 2.4.0) and expat 1.95.5. I haven't upgraded expat so it doesn't have anything special passed to it, and when I installed freetype2 (2.1.7), I just ran ./configure with no extra options.

My end goal is to install nicotine which requires PyGTK1.99.16, but I grabbed 2.0 anyway.


tfdml37 04-04-2004 12:43 AM

bump.. any one got any ideas? I'm still stuck

Andrew Benton 04-04-2004 05:21 AM

Well it seems to have a problem with the freetype headers. You could try pointing it towards them with a
export CPPFLAGS="-I/usr/include/freetype2"
obviously that's not going to work if the freetype headers are somewhere else so it's up to you to find them with
find /usr -name freetype2
and alter the flag accordingly. If you can't find the freetype headers, reinstall freetype but make sure you do it over the top of what you already have or you'll end up with two copies of things which will cause problems.

tfdml37 04-07-2004 01:10 AM

hrm. Well, I got it to work. On the site, it mentioned that release 2.2.2 'changed #include syntax to follow new freetype rules' so I downloaded the newer version and tried to install it. I got a different error (I don't remember what it was), but I fixed it by doing 'make install' in the freetype source directory (the instructions say to just do make twice, but the make install actually put stuff where fontconfig was looking for them.) After that pango still couldnt find fontconfig.pc in the pkgconfig directory so I manually copied the fontconfig.pc in the fontconfig source directory and put it in the pkgconfig directory. Pango finally installed after that, but it feels like a great big kludge.... now on to battle with gtk

All times are GMT -5. The time now is 03:55 AM.