LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   Installing ALSA Drivers on RH9 for Asus P4PE-X on-board sound (https://www.linuxquestions.org/questions/red-hat-31/installing-alsa-drivers-on-rh9-for-asus-p4pe-x-on-board-sound-164517/)

tkorstanje 03-31-2004 08:21 AM

Installing ALSA Drivers on RH9 for Asus P4PE-X on-board sound
 
After much time searching on the internet, how to install the ALSA drivers properly, I still can get it fixed.... feel like a terrible newbie (well, I am a Linuxnewbie, however I tried just about everything I could think of...).

When following the steps mentioned in the 'mini-HowTo for ALSA'-thread, I get the error message from alsamixer:

Code:

alsamixer: function snd_ctl_open failed for default: No such device
Modprobe of the snd-intel8x0 module gives the following error:

Code:

/lib/modules/2.4.20-30.9/kernel/sound/pci/snd-intel8x0.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-30.9/kernel/sound/pci/snd-intel8x0.o: insmod /lib/modules/2.4.20-30.9/kernel/sound/pci/snd-intel8x0.o failed
/lib/modules/2.4.20-30.9/kernel/sound/pci/snd-intel8x0.o: insmod snd-intel8x0 failed

I've got a on-board soundcard on an Asus P4PE-X motherboard, which I believe uses the Intel i810 chipset. refferred to in lspci as follows:

Code:

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio (rev 02)
and in lsmod as:

Code:

soundcore              6404  2  [i810_audio snd]

I used the --with-redhat=auto, --with-cards=intel8x0, --with-oss=yes, --with-sequencer=yes flags at the ./configure step for the ALSA driver. I use RH9, kernel 2.4.20.

The most stupid thing is, that at one point I DID get the sound working, however after a reboot it failed again and I can't trace my then followed steps...
Can anybody help?

GoinEasy9 03-31-2004 06:14 PM

Hey dude...have the same motherboard....go to the asus web site and download the Alsa drivers...along with the instructions directly from there. I think they are specific for the P4PE-X motherboard.

the name of the driver to download is alsa-driver-0.9.1ADI.tgz

read both sets of instructions..the one that starts with explanation of password protection is the one a used to install the driver...you don't need a password...just start at step 3. where your untaring the tgz file...

good luck
Tom

tkorstanje 04-01-2004 08:30 AM

Thanks for this post, however I keep on getting 1 error message, when trying to insmod the snd module (which the "make install" step also tries to do)
(the same error message appears when modprobing snd-intel8x0):

Code:

[root@localhost log]# insmod snd
Using /lib/modules/2.4.20-30.9/kernel/sound/acore/snd.o
/lib/modules/2.4.20-30.9/kernel/sound/acore/snd.o: unresolved symbol schedule_work

Anybody an idea what the problem may be?

(I tried to read the snd.o module, however this can't be read by gedit, and I don't know how it is readable)

GoinEasy9 04-01-2004 08:09 PM

Wish i could help more...but the error seems to be related to source code that's particular to RedHat...i use Mandrake....

when i did ./configure...i only included --with-cards=intel8x0...maybe you could try that...i'm still very much a newbie...seems you need someone more familiar with redhat

keep the thread up...one of the LQ members will eventually have the right answers for you....took me 2 weeks to get my sound working...

you culd also search the threads...search using AC97 or AC'97....i got a lot of answers that way

Good luck
Tom

inquirer 08-20-2004 03:27 AM

yo tkorstanje, did you manage to install alsa in your linux? I have the same motherboard and linux distribution like you, which are P4PE and redhat linux9. btw you got schedule_work error when you try to modprobe alsa, well according to the reference that I have this is because RedHat
shipped the kernel with incomplete implementation of workqueue.
For solving this problem, run the following on the top of alsa-driver
directory:

% touch include/linux/workqueue.h

and run "make clean", "make" again.

hope that's help


All times are GMT -5. The time now is 10:56 AM.