-   Red Hat (
-   -   installing adobe flash player in RHEL version 5 (

nithya.r 12-18-2009 10:34 AM

installing adobe flash player in RHEL version 5
i tried the following commands in the terminal ..but was not able to install flash player....i kept getting errors or windows like "exception occured"..please do help me...i'm a newbie to linux and not able to play any vides

gzip -d install_flash_player_10_linux.tar.gz
tar -xvf install_flash_player_10_linux.tar
tar -xvf install_flash_player_10_linux.tar
cd install_flash_player_10_linux.tar
cd install_flash_player_10_linux.tar
tar -xvf install_flash_player_10_linux.tar
cd install_flash_player_10_linux.tar

raju.mopidevi 12-18-2009 10:44 AM

when extract install_flash_player_10_linux.tar.gz you will get

you have to place that "" file into the /usr/lib directory.

DrLove73 12-18-2009 03:36 PM

there is adobe repository with rpm in it that installs without a problem:

nithya.r 12-19-2009 04:10 AM

i got the following error when i clicked on the link,pls help
Component: pirut
Summary: TB3518121c ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Traceback (most recent call last):
File "/usr/sbin/system-install-packages", line 361, in ?
File "/usr/sbin/system-install-packages", line 354, in main
pkginst = SinglePackageInstaller()
File "/usr/sbin/system-install-packages", line 66, in __init__
GraphicalYumBase.__init__(self, False)
File "/usr/lib/python2.4/site-packages/pirut/", line 137, in __init__
File "/usr/lib/python2.4/site-packages/yum/", line 139, in doConfigSetup
File "/usr/lib/python2.4/site-packages/yum/", line 205, in _getConfig'init')
File "/usr/lib/python2.4/site-packages/yum/", line 176, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/", line 110, in init_hook
login_info = up2dateAuth.getLoginInfo()
File "/usr/share/rhn/up2date_client/", line 217, in getLoginInfo
File "/usr/share/rhn/up2date_client/", line 168, in login
server = rhnserver.RhnServer()
File "/usr/share/rhn/up2date_client/", line 149, in __init__
self._server = rpcServer.getServer()
File "/usr/share/rhn/up2date_client/", line 168, in getServer
raise up2dateErrors.SSLCertificateFileNotFound(msg)
SSLCertificateFileNotFound: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT

Local variables in innermost frame:
lang: en_US
rhns_ca_cert: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
log: <up2date_client.up2dateLog.Log instance at 0x9500bec>
proxyUser: None
cfg: <up2date_client.config.Config instance at 0x9500a2c>
ca: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
rhns_ca_certs: ['/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT']
proxyPassword: None
proxyHost: None
s: <RetryServer for /XMLRPC>
refreshCallback: None
serverUrls: ['https:///XMLRPC']
env: LANG
msg: ERROR: can not find RHNS CA file: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
serverList: <up2date_client.rpcServer.ServerList instance at 0x9500b4c>

nithya.r 12-19-2009 04:19 AM

still unable to install flash
i placed in /usr/lib

i tried the foll:
Desktop# tar -xvf
lib# tar -xvf

tar: This does not look like a tar archive
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers
tar: Error exit delayed from previous errors
[root@localhost lib]# ./configure --prefix=/usr/lib/
bash: ./configure: No such file or directory
[root@localhost lib]# make install
make: *** No rule to make target `install'. Stop.


EricTRA 12-19-2009 04:23 AM


The file is no tar archive so you don't have to process it with tar. If you place the file in the correct directory you should be able to play videos like from YouTube in your browser.

Kind regards,


nithya.r 12-31-2009 10:01 PM

how to download and install YUM player in rhel5 ? please help

TB0ne 12-31-2009 11:44 PM


Originally Posted by nithya.r (Post 3810485)
how to download and install YUM player in rhel5 ? please help

Should just have to follow what folks have already told you. Follow the instructions you were provided.

DrLove73 01-01-2010 06:39 AM

YUM is package installation utility and you should already have it installed on your system. just type

rpm -qa yum
in a terminal, and with root privilegies. It will show yhat version of you you have installed.

then download and install it with

rpm -ivh adobe-release-i386-1.0-1.noarch.rpm
also from terminal, and with root privilegies. that will install you adobe repository. next install flash player with

yum install flash-plugin
also in terminal and with root privilegies.

All times are GMT -5. The time now is 10:44 AM.