LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 10-18-2011, 11:31 AM   #1
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Rep: Reputation: 0
How to install RHEL 6.1with DVD , laptop fails to recognize the same DVD


Hello there I get to a point where installation is stuck because my laptop doesn't recognize the Dvd

its strange the DVD was created using WINDOWS 7 default image burner - Roxio I guess on a different laptop.

I get "The Red Hat Enterprise Linux disc was not found in any of your CDROM drives. Please insert ~ and press OK to retry.

is this a driver(s) issue ..I was able to install RHEL 5.5 Server without any problems on this same laptop ....

I cant understand whats going wrong ... I have also tried nomodetest acpi=off but this doesn't help either ..Please let me know if there is a a solution for this please help ...thanks again to you all.....
 
Old 10-18-2011, 01:31 PM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: Devuan
Posts: 3,653
Blog Entries: 33

Rep: Reputation: 283Reputation: 283Reputation: 283
Hi, looks like the dvd was not made to boot.

That is as long as you, 1) checked the md5sum before burning and 2) verified the burn was successful.

Not much experience with win7, sorry.

regards Glenn
 
Old 10-18-2011, 02:58 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
i did not know that windows natively supported burning a iso .
Must be new in 7 .
I have been using K3B for years and
and "InfraRecorder" on windows because MS never supported burning an ISO.

Was that old RHEL 5.5 ( RHEL 5.7 is the CURRENT in the 5 series ) dvd burned on the same win7 box as the RHEL6.1 dvd

have you read the Red Hat documentation
https://access.redhat.com/knowledge/...erprise_Linux/
also BEFORE you buy the REQUIRED license ( 1 year $299 US ) chack if everything is woirking on that laptop

rhel was designed for a server rack and NOT everything is going to work right on a laptop
things like
The mouse pad
The sound
The graphics
might not work well
or might not even be supported.

Last edited by John VV; 10-18-2011 at 03:02 PM.
 
Old 10-19-2011, 12:36 AM   #4
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Original Poster
Rep: Reputation: 0
hello there the burn was successful and I was able to boot the RHEL 6.1 stable, and about RHEL 5.5 - yes it was burnt using NERO in windows XP and not with default burning software in WIN 7.No errors were found while/after burning ..

RHEL 5.5 SERVER TIKANGA bootable dvd works fine even now on my laptop and other systems too.


I am able to select the keyboard layout etc .... but at one point it asks for the media and I select DVD rom ...but its says not found - the error message i described above.


I came across one blog http://www.if-not-true-then-false.co...l-screenshots/ where guys had posted similar kind of issues while installing ...Yes I would definitely buy that DVD copy once I am able to install RHEL 6.1..
 
Old 10-19-2011, 01:12 AM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
Quote:
but at one point it asks for the media and I select DVD rom
that is for ADDITIONAL software repos and for ADDITIONAL hardware drivers if needed ( linux drivers)
leave that alone

also rhel and CentOS are very well known for messing up an install if you pick and choose the software to install ( aka a busted install)

use one of the default set ups
like - desktop with Gnome

then AFTER the install
customize the software .

also be advised that not all laptops will work right with rhel
you might have some hardware problems .
 
Old 10-19-2011, 07:04 AM   #6
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Original Poster
Rep: Reputation: 0
ok ..I have tried installing RHEL 6.1 from USB pendrive ..using a software called Unetbootin I first made the normal 4gb pendrive into a bootable USB system and its very fast ...I get to the screen where I need to select the devices and I choose

“Basic storage device.” at this point the system shows the round animation of cursor and then the error message comes up...

I have attached to this post the photo of the error message ..its readable though ..my apologies I took it from a 1.3 mp camera..

its says STARTING GRAPHICAL INSTALLATION ....BACKTRACE HAS 20 CALLS CALLS ON STACK........................Anaconda died after receiving signal 6.
install exited abnormally


if you can carfully look at the shot its something related to python also ....



there is nothing such as "use one of the default set ups
like - desktop with Gnome " ...


please let me know any more troubleshooting steps ..i have got this far ..may be I can complete the installation since I believe RHEL 6.1 can also be installed on laptop.

I am not proving anybody wrong its just that i came across the post which mentions that Linux now adays can be installed on almost new compatible hardware ...

Thanks to you all again for the help and support
Attached Thumbnails
Click image for larger version

Name:	19102011(001).jpg
Views:	52
Size:	199.9 KB
ID:	8203  

Last edited by getasif; 10-19-2011 at 07:20 AM.
 
Old 10-19-2011, 10:34 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
Quote:
RHEL 5.5 SERVER TIKANGA bootable dvd works fine even now on my laptop and other systems too
so you DO have a paid for red hat account .
rhel5 is running on multiple computers

have you asked your all ready paid for support

they will know more about installing on laptop hardware .


from above
the dvd got into the gui installer but the usb did not ?
is that right ?
did you run the dvd check on the first screen of the installer ?
and did the dvd pass ?
 
Old 10-19-2011, 12:49 PM   #8
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Original Poster
Rep: Reputation: 0
Ok Jon VV I have finally resolved it by myself ...I installed nero and took a new blank dvd,burnt the image with nero and then rebooted the laptop ..and it all worked I was able to install customized packages for a total of 1635 ...it even gave the message INSTALLING BOOTLOADER at the end.The DVD was ejected automatically and on the screen I clicked on the message box that read "REBOOT"

After rebooting guess what!!! the GRUB wasn't installed and i was booted into WINDOWS XP ...so now that I have had a normal installation ,the grub isn't available to me .....

any ideas about how to fix this now........


thanks for all the help
 
Old 10-19-2011, 04:12 PM   #9
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Original Poster
Rep: Reputation: 0
PLEASE NOTE I TRIED THIS WITH A LIVE UBUNTU CD

hello there heres what i got when i typed the command chroot /mnt/sysimage grub-install /dev/sda

The file /boot/grub/stage1 not read correctly.

I also tried this
# grub
> find /boot/grub/stage1
>root (hd0,8)
>setup (hd0)

but it gave me error as follows

find /boot/grub/stage1
(hd0,8)

grub> root (hd0,8)

grub> setup (hd0)
Checking if “/boot/grub/stage1″ exists… yes
Checking if “/boot/grub/stage2″ exists… yes
Checking if “/boot/grub/e2fs_stage1_5″ exists… yes
Running “embed /boot/grub/e2fs_stage1_5 (hd0)”… 17 sectors are embedded.
succeeded
Running “install /boot/grub/stage1 (hd0) (hd0)1+17 p (hd0,8)/boot/grub/stage2
/boot/grub/menu.lst”… failed

Error 22: No such partition


linux is installed on /dev/sda8 as shown by the fdisk -l command

can u please debug this ...thanks again for the help

Last edited by getasif; 10-19-2011 at 04:29 PM.
 
Old 10-20-2011, 02:06 AM   #10
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,622

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
I am guessing that grub did install
but NOT to the MBR .I am guessing there is a factory made hidden " recovery " partition
and grub installed there
BUT this is odd "(hd0,8)"
you put rub on the 9th partition
? just how many partitions ore on this laptop ????
gurb can NOT be installed on an extended partition
it must be one of the 4 primary's


i think you might want to reformat
reinstall xp
then reinstall rhel6


you installed grub on an extended partition
it will not boot from there

reinstall both os's with a cleaned partition layout
or try and install grub onto the MBR ,overwriting xp's bootloader

grub can boot xp
-- just a warning --
xp might try to "fix" a working "grub" and reinstall ms's bootloader
 
Old 10-21-2011, 12:53 AM   #11
getasif
LQ Newbie
 
Registered: Sep 2009
Posts: 26

Original Poster
Rep: Reputation: 0
hello there I have now successfully installed RHEL 6.1 stable on my laptop and this is how I did it.

When I had installed win xp I also installed partition magic software and formated the last drive with ext3

Next time I booted with a new copy of RHEL 6.1 burnt with nero and I just installed on the ext3 formatted drive without formatting it again

I then tried all ways of restoring the grub ..but could not succeed

Finaly I decided to install again but this time I made sure about formatting the drive ...and I was surprised to see ext4 ..so I went ahead and did the same installation procedure thereafter ...

The grub along with RHEL 6.1 and Win XP is now available and I can access both the OSs easily ...thanks again for all your help and ideas ...and some things I have learnt the hard way

1) always keep backup of Linux drive ...

2) when executing command like dd ..use the value for bs=446 I had used bs=512 ...lost the data in LVM ..i was able to get back the data from NTFS partition using bootable testdisk but not my Linux - LVM drive

3)never trust windows and the inbuilt native - default burning software ...USE NERO OR NERO-LINUX OR SOMETHING THAT IS STANDARD AND WORTH


hope you all agree with me ......thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FC11 - K3B works fine with LG-DVDRW SATA for CD-R, CD-RW, DVD+RW, but fails DVD+R rylan76 Linux - Software 2 11-15-2010 07:05 AM
Burning dual layer dvd (DVD DL +R) fails using k3b, Nero 4 Linux, Gnome CD/DVD Creat skyxn3t Linux - General 1 09-03-2010 08:26 PM
Debian 5.0.4 DVD (AMD64) does not recognize Toshiba L500D-ST2532 DVD Drive rekhillbill Linux - Newbie 3 05-04-2010 04:00 PM
Install doesn't recognize dvd player apnorton Linux - Software 1 05-30-2007 09:34 AM
Every DVD Player Fails to Play DVD Movie in SuSE 9.2 Pro....Please Help ! ! ! bedi-beparwah SUSE / openSUSE 2 03-14-2005 06:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration