LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   Help:(linux can mount the fat32 correctly,but dos can't recognize the partition.) (https://www.linuxquestions.org/questions/red-hat-31/help-linux-can-mount-the-fat32-correctly-but-dos-cant-recognize-the-partition-159762/)

zhgjerry 03-19-2004 07:58 AM

Help:(linux can mount the fat32 correctly,but dos can't recognize the partition.)
 
I have some question about fat32 to ask,
There're two harddisks in my computer,I have installed three operate systems.the first disk is win98 in drive c,winxp in

drive d.they are all fat32 filesystem.the second drive is linux (ext3).one time the boot record about Grub is lost,so i use

the following command to rescue it.(i can't remember very clearly!)

install (hd1,0)/boot/grub/stabel1 (hd0) p (hd1,0)/boot/grub/menu.1st

after i reboot the computer,the system stoped at the "grub" displaying in the screen.It can't boot linux.
Then i boot computer to DOS,the command "dir c:" tell me the drive c is invailde,
fdisk only know the size of drive c,but display the system of drive c unkown.
then i try the
root(hd1,0)
setup(hd0)
then the grub can boot up,i can mount the win98 partition successfully.All the files in the partition are correct.
I have use diskedit,nu8,pq6 for dos,but they all can't access the drive c,PQ can only tell me the drive C is fat32 and the

size of it.
I check the MBR,I think it may be correct.May be the problem is in the first sector of drive C.

Can anyone help me?thx!
(My English is not very good,please don't laught at me :) )

maxut 03-20-2004 09:57 AM

actually i dont know grub commands. if my mbr craches (it happens when i setup windows again), i boot from redhat cdrom with "linux rescue" option. i create /mnt/lnx directory then mount my / patition on my disk in /mnt/lnx patition then change root (/) to this directory.. (chroot /mnt/lnx) finally i give this command "grub-install /dev/hda".. grub installs itself to MBR. i tried this most of time, it always worked with no problem..

the commands u typed to install grub, migth be wrong. it migth write itself to first record of fat32.. if u still reach the fat32 from linux, first backup your data then try to install grub as i do..

i hope it works.
PS: im not good enough english either. :)

zhgjerry 03-21-2004 04:29 AM

Thanks for your help!

I have checked the boot sector of driver C.And I find the message of Grub in it.And can't find the "NTLDR",I think it has been destroyed.I don't want to reinstall the windows,I only think out a fool idea.I try to copy the "NTLDR" boot sector of others whose partition is near to me to rescue my disk.I hope it can work.

Do you have some better idea?Thx!

maxut 03-21-2004 04:45 AM

cool. make sure fat32 is marked as active. dont forget to check other files.. ntdetect.com boot.ini etc..

i hope it will work.

zhgjerry 03-22-2004 12:37 AM

A good news!

:cool: I have readed the specification of the FAT32 from Microsoft.I find there is a backup of boot sector in the harddisk.I saved it to file and read it.I find that it's too old to use,it is just to boot win98.However i recover the boot sector with it.And now i am posting in the win98:) .

the rest thing is how to rescue the winxp,how can i put NTLDR into the boot sector?

I really don't want to "rescue install" winxp,because it will kill grub again,and it's hard for me to find the cd of winxp!Is there a easy way to recover the winxp?Or can I rescue it through a 3.5" disk.

Thx!

maxut 03-22-2004 12:52 PM

im glad to hear that :)

sorry i dont know how to do that. (NTLDR).. u may try to copy these files (if u have them) to c:\ ..i hope it will work.
"ntldr, ntdetect.com, boot.ini"
maybe the following files r needed too, im not sure
"bootsec.dos, bootfont.bin"

dont worry about MBR record if u have redhat CDs. u may install grub to MBR easyly as i told b4. it takes 2 minutes.

maxut 03-26-2004 11:40 AM

http://www.tldp.org/HOWTO/Linux+NT-Loader.html#toc1

read it please.

zhgjerry 03-27-2004 08:55 AM

Thank you very much!

I've rescued all my OS.

The winxp i repair it as follows:

I use DISKEDIT opening the first harddisk.
and i search "NTLDR is missing",thourgh more than 2000 sectors it found a matched sectors.I copy it to a file.Then i open it in win98 thourgh "UltraEdit"
I find Its structure is very like a boot sector.But its BPB(BIOS Parimatar Block) is a little different from my backup boot sector.So i modify the BPB to match the backup boot sector.Then i load the file,and covered my boot sector.Then it can works:)

very thanks to your help!

I'm sorry to tell you that the HTML pages can't open in my computer.
maybe it's the problem of the serve.
I am a chinese boy.
can i make a friend with you?:)

maxut 03-28-2004 01:53 AM

im glad to hear that!
im a turkish...
sure we r already friends! :)

why cant u open html in your browser? doesnt your browser support HTML?

zhgjerry 03-28-2004 10:24 AM

;)
If a browser can't read HTML,can it be call as a "browser"?

Maybe it was forbided to visit by my gateway in the school.We can't visit the pages outside one year before!

maxut 03-29-2004 06:29 AM

ohh i got it.
is it foolish? why dont they allow u serach over net? at least they could prefer a proxy server. so they would allow u for clean sites.

zhgjerry 03-30-2004 10:23 AM

I only wanted to make a joke:) ,don't care for it!

Can u mail the web page to me?Thx!

jiguangpianyu5000(at)sina.com

can u leave a email to me?


All times are GMT -5. The time now is 04:03 AM.