-   Red Hat (
-   -   gnome-power-manager error ( 12-15-2013 07:51 PM

gnome-power-manager error
I was receiving a gnome-power-manger error after the password was entered. Just a blank screen. I found how to log in doing an Alt-F2, brings me to a text login.

Is there a way to bring back the gui interface?


Ztcoracat 01-04-2014 01:49 AM


Try startx if that doesn't work try the first 3 on this page-
In the past startx worked for me:-

Do you remember or can you post the gnome-power-manger error? 01-05-2014 08:28 PM

Tried the startx gave me a lots of errors:


xauth: create new authoring file /root/.servrauth.22975

_XSERVTtransSocketUNIXCreatedListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running

Fatal server error:
Cannot establish any listening sockets - Mas sure an X server isnt' already running
Please consult the Red Hat, Inc. Support
at for help
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information
Server terminated with error (1) Closing Log file.
Invalid MIT-MAGIC-COOKIE-1 keygiving up.
xinit: Resource temporarily unavailable (errno 11): unable to connect to X Server
xinit: No such process (errno 3): Server error.

End of message.

The cat of the Xorg.0.log is the same as above.

I did a ps -ef | grep XSERV and nothing came up.

Thanks for your help


Ztcoracat 01-05-2014 10:44 PM

I could be wrong but it seems as if the server is crashing-

It could be that some files are corrupt or even missing.
This is out of my reach as I am not on a server and I don't know how to repair a socket error. Sorry-
I'll ask a Moderator to join in.:)

I found this:

You can remove those sockets and locks if their session (or owner) is no longer present, normally they have a valid user, deleted users might have leftovers (ls -l will show a uid instead of a name)

Aside from that; I learned from a man running Open Suse that it too comes with Xorg which is not supported by the legacy driver. IF it's a driver issue to get the 3D acceleration to work you have to recompile the kernel and reinstall kernal pkgs and that may help-

TobiSGD 01-05-2014 11:04 PM

startx fails because there is already a X server running (displaying a black screen, if I understand the OP correctly).
What is the exact error-message you get from gnome-power-manager? 01-07-2014 10:08 PM

This is the error that comes up in a dialog box when the system first boots.

Install problem!

The configuration defaults for GNOME Power Manager have not been installed correctly.
Please contact your computer administrator.

I am the computer admin and don't know how to solve this problem. lol.

Thanks for your help!!


Ztcoracat 01-07-2014 11:20 PM


I am the computer admin and don't know how to solve this problem. lol.
Been there done that!

This link might help-

What distribution are you running?

Ztcoracat 01-08-2014 12:45 AM

From what I have read online in several Linux forums a lot of folks are having this issue after a system upgrade:-

When the Gnome Display Manager appears again try Ctrl+Alt+F1 which will switch you to a text based login prompt.
Login in using an account with username and password.

Try cleaning your apt-get cache: (providing your using a distro that uses APT for it's cmdline utility)

sudo apt-get clean
sudo apt-get autoclean

That will free up the space used by package archives which are in /var/cache/apt/archives

Press Ctrl+Alt+Del to reboot again.
That should help- 01-08-2014 06:23 PM

I am running Redhat 6.5.

Tried the apt-get, that is not on my machine.

TobiSGD 01-08-2014 06:36 PM

At this point it may be the best to just ask the Red Hat support.

Ztcoracat 01-08-2014 06:58 PM

The number is 1-888-REDHAT-1 (or) 1-919-754-3700--

All times are GMT -5. The time now is 01:34 PM.