LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 07-23-2007, 03:27 PM   #1
perrym8
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Rep: Reputation: 0
Failed to load module "ati" (module does not exist, after upgrad from Redhat 3 to 5.


I recently upgrading from Redhat Ent. release 3 to release 5. Now I can't get the video to work. It appears that I need to load the video driver but I haven't been able to find it. I may need to update Xfree86 but I'm not sure if that's the problem.

Any help would be appreciated. Here's more info to help with the diags....


Machine Type: Dell 2600 with a ATI Rage XL (Mach64)

When I type X here's what I get:

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.9-42.ELsmp i686 Red Hat, Inc.
Current Operating System: Linux tildbs01 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686
Build Date: 09 January 2007
Build ID: xorg-x11-server 1.1.1-48.13.el5
Before reporting problems, check
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 23 14:59:03 2007
(==) Using config file: "/etc/X11/xorg.conf"
(EE) Failed to load module "ati" (module does not exist, 0)
(EE) No drivers available.



from xorg.conf:

[B]B]
Section "Device"
Identifier "Videocard0"
Driver "ati"
VendorName "Videocard vendor"
BoardName "ATI Mach64"


This is from the xorg.0.log


(II) Loading font Type1
(II) LoadModule: "ati"
(WW) Warning, couldn't open module ati
(II) UnloadModule: "ati"
(EE) Failed to load module "ati" (module does not exist, 0)
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.1
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input/kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.1.1, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.6
(EE) No drivers available.

Fatal server error:
 
Old 07-23-2007, 03:55 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
the driver no longer exists. just run system-config-display to reconfigure X
 
Old 07-24-2007, 11:14 AM   #3
perrym8
LQ Newbie
 
Registered: Jul 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks

Thanks - I'll give it a try today and reply with the results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg -- (EE) Failed to load module "glx" (loader failed, 7) windowsrefugeeX Linux - Software 10 09-23-2009 06:51 PM
Failed to Load Kernel Module "i915" alkos333 Slackware 3 01-13-2007 10:08 PM
"Failed to load module "i915"" Kane635 Linux - Software 0 11-22-2004 09:17 PM
Xorg - (EE) Failed to load module "i810".... frogboy Linux - Software 2 10-16-2004 12:39 PM
RedHat9 Failed to load module "bitmap" bkersey Linux - Software 0 10-25-2003 02:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 12:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration