-   Red Hat (
-   -   Failed Install For VirtualBox (

carlosinfl 08-26-2010 10:19 AM

Failed Install For VirtualBox
I installed CentOS however during package selection, I deselected every option because I don't need or want the bloated dependencies however now when I try and install a 3rd party RPM from Oracle (VirtualBox), it fails:


[root@vbox ~]# cat /var/log/vbox-install.log
** Compiling vboxdrv
Makefile:159: *** Error: unable to find the sources of your current Linux kernel. Specify KERN_DIR=<directory> and run Make again.  Stop.

I did make sure I have the 'kernel-headers' package installed as show below but I don't know if that is the exact package VirtualBox is complaining about.


[root@vbox ~]# rpm -qa kernel-headers

Anyone know how I can resolve this issue and correctly install VirtualBox on CentOS 5.5 64-bit?

Below is the exact error I got when installing the VirtualBox RPM:


Creating group 'vboxusers'. VM users must be member of that group!

No precompiled module for this kernel found -- trying to build one. Messages
emitted during module compilation will be logged to /var/log/vbox-install.log.

Compilation of the kernel module FAILED! VirtualBox will not start until this
problem is fixed. Please consult /var/log/vbox-install.log to find out why the
kernel module does not compile. Most probably the kernel sources are not found.
Install them and execute as root.

  /etc/init.d/vboxdrv setup

*****I installed kernel-devel package and that fixed it.*****

AlucardZero 08-26-2010 10:45 AM

Off ZRT. Please mark your thread solved by using Thread Tools.

All times are GMT -5. The time now is 08:56 PM.