-   Red Hat (
-   -   ext3-fs warning device ext3_clear_journal (

sKiZZiT 08-20-2004 08:45 AM

ext3-fs warning device ext3_clear_journal

I'm having trouble booting my RH9.0 Linux. What happened was, my mounted secondary HDD suddenly failed to response, so I tried to shutdown my Linux. It failed and showed no response, so I just press the RESET button.

When I tried booting again, I get a problem SIMILIAR to the following :


kjournald starting. Commit interval 5 seconds
EXT3-fs warning (device hdb1): ext3_clear_journal_err: Filesystem error recorded from previous mount: IO failure
EXT3-fs warning (device hdb1): ext3_clear_journal_err: Marking fs in need of filesystem check.
EXT3-fs warning: mounting fs with errors, running e2fsck is recommended
EXT3 FS on hdb1, internal journal
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
attempt to access beyond end of device
hdb1: rw=0, want=274989144, limit=268413957
EXT3-fs error (device hdb1): ext3_get_inode_loc: unable to read inode block - inode=17187087, block=34373642
Aborting journal on device hdb1.
ext3_abort called.
EXT3-fs abort (device hdb1): ext3_journal_start: Detected aborted journal
Remounting filesystem read-only


Now, I can't boot into my Linux because of this crap. Anyone know a fix to this? I'm terribly desperate to fix this cause my Linux HDD has my thesis project (I did back some stuff up but those aren't the most recent ones!) and many other stuff in it!!!

sKiZZiT 08-20-2004 05:08 PM


sKiZZiT 08-24-2004 09:35 AM

WTF? No one can help?

elfoozo 10-31-2004 02:26 PM

I had a problem with my ext3 journels once... fsck blew them away when running a disk check.

I used tune2fs to re-create the journal so I would imagine you could use tune2fs to remove then re-create your corrupt journal.

All times are GMT -5. The time now is 12:40 PM.