LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   error during compiling rpms using rpmbuild (https://www.linuxquestions.org/questions/red-hat-31/error-during-compiling-rpms-using-rpmbuild-111940/)

jogurt666 11-03-2003 02:32 PM

error during compiling rpms using rpmbuild
 
i've installed latest rpmbuild. i want to compile

NVIDIA_kernel-1.0-2880.src.rpm

to get a

NVIDIA_kernel-1.0-2880.rpm

file under

/usr/bin/redhat/RPMS/i386

directory. the only thing i should do is to type:

#rpmbuild --rebuild NVIDIA_kernel-1.0-2880.src.rpm

and after that install compiled rpm file. but the problem is the file won't get created! it says something like that:

bootmeister user doesn't exist - using root
bootmeister group doesn't exist - using root
bootmeister user doesn't exist - using root
bootmeister group doesn't exist - using root

what the hell is wrong. could any one try compiling this file and in the case of success tell me how to do it or send me the file (mail me and i'll give you a fast ftp to upload)? i beg you, help me, otherwise i can't start X Server!

grym 11-03-2003 03:39 PM

Why are you using that old driver version?

I would just get the new installer from the Nvidia site and use it. It installs easily.

Long ago I did that build and it worked fine using this command

rpm -rebuild NVIDIA_kernel-1.0-2880.src.rpm

grym 11-03-2003 03:46 PM

o by the way the new rpm is output somewhere like

/usr/src/RPM/i368/

or some thing like that. Sorry it's been a long time since I used a rpm based distro. You may have to look around in there a bit or do a find.

jogurt666 11-04-2003 02:39 AM

well i downloaded that driver yesterday. the output directory is correct, but there is no output file built. there is also a *.run file with the driver, but after i install it and customize /etc/X11/XF86Config and finally reboot, the driver still doesn't works (X Server doesn't start as i type startx)

grym 11-04-2003 06:47 AM

Download this file.

http://download.nvidia.com/XFree86/L...-4496-pkg2.run

Then as root type sh NVIDIA-Linux-x86-1.0-4496-pkg2.run

Answer the questions. Then after the installer finishes type modprobe nvidia
Next edit your /etc/XF86Config. Now if all the correct info is in there you should be able to start X without having to reboot.
If X won't start post you XF86Config and if you get any errors post them also.


All times are GMT -5. The time now is 07:43 PM.