-   Red Hat (
-   -   Disabling CPUID - kernel panic! RedHat 6.2 & AMD CPU (

rhinds1369 11-18-2005 01:09 PM

Disabling CPUID - kernel panic! RedHat 6.2 & AMD CPU
Installed RedHat Linux 6.2 on my system and everything seems fine until I reboot. During boot, it gets to the message "Disabling CPUID" then I get a protection fault which ends in a kernel panic and the system halts. I had this working at one time then this problem started so I wiped out the disk (Seagate disk utilities "zero-fill" entire drive). Hardware details:

ASUS A7A266 motherboard ALI chipset
AMD Athlon XP 1200
256 MB RAM
2x - 20GB ATA HDD
Netgear FA311 10-100 Ethernet
nVidia Riva TNT2 AGP video 32MB
PCI modem
ASUS 52x max CDR

The exact error message:

Disabling CPUID Serial number... general protection fault:0000

This is followed by a register and stack dump (I can provide the details if necessary) then:

Kernel panic: Attempted to kill the idle task!
In swapper task - not syncing

At this point the system is hung.

GrueMaster 11-18-2005 01:23 PM

With Redhat 6.2, there could be any number of hardware related support problems. First, I'd highly recommend using a newer distribution, or at least a newer kernel. It is quite possible that the kernel just can't configure that processor properly. I'm not too familiar with the AMD line (working at Intel proccessor validation for 7+ years left me a little biased), but the older kernel (2.2, if I remember correctly) just doesn't know about the newer equipment.

rhinds1369 11-18-2005 01:31 PM

Unfortunately, I can't do that. I'm creating a test box for an existing realtime distribution system that is using this version. I need to make sure that changes I test will work on the production system.

GrueMaster 11-18-2005 03:25 PM

Sorry for the late response, had to search my archive for a RH 6.x CD. Since you can boot from the CD and install it, I think the default kernel that installed is probably not compatable with your particular processor (I think back then the i686 kernel was optimized for Intel specific cpu's, like the PII/PIII).

I'd recommend rebooting from the CD into rescue mode (type "linux rescue" at the cd boot prompt) and follow these steps to put a different kernel in place:

mkdir /mnt/sysimage
mount /dev/hda1 /mnt/sysimage #I'm guessing this is the root partition. You'll need to check

cd /mnt/sysimage
bin/cp /mnt/source/RedHat/RPMS/kernel-2.2.xx-i586.rpm tmp #sorry, I only found RH 6.1 and I can't remember what kernel 6.2 had - you'll need to verify
chroot .
rpm -e kernel-2.2.x --nodeps #again, you'll need to swap in the kernel version. the --nodeps will illiminate dependancy errors
rpm -i /tmp/kernel-2.2.*

This should boot you up with a kernel that is i586 optimized (not perfect, but...). What processor is your production system using? Ideally, you will want to install the same kernel that matches that processor's build (assuming it is ia32 based).

rhinds1369 11-18-2005 04:13 PM

Thanks and I'll give that a try. But what I don't understand is this was working at one time. I got pulled off the project for a while and am just now returning to it so I don't remember how/why it worked before. I was wondering if there was a parameter to linux I could enter at boot time, like "cpuid=0" or something. Is there a list of the parameters somewhere that I can check out?

GrueMaster 11-18-2005 04:33 PM

In the kernel source directory, under Documentation, there is a text file called kernel-parameters.txt. One thing you might try, is noapic. I had issues back with this series on a dual processor PIII system back in the day, and that was the only resolution until the 2.4 kernel stabilized.

GrueMaster 11-19-2005 11:27 AM

By the way, which kernel are you using? I've been looking through the 2.2.24 kernel, and haven't found that error message yet. I just found a 6.2 ISO online this morning, and am downloading it, so I can browse the actual system.

rhinds1369 11-20-2005 11:32 AM

The kernel is 2.2.14-5.0. That looks odd to me but... Anyway, I tried your earlier suggestion and had no joy - I'll have to give you the specific error messages tomorrow. Also tried the noapic - again, no joy. I couldn't find the kernel-parameters.txt file either.

GrueMaster 11-20-2005 12:44 PM

The kernel-parameters.txt file is part of the kernel-source rpm file.

I finally found an ISO on the net, and will be able to look into this more after the holidays. Have a good thanksgiving (if you are state-side).

All times are GMT -5. The time now is 10:44 AM.