LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 01-23-2004, 01:46 AM   #1
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Rep: Reputation: 15
Disable Monitor Sleep [in fluxbox and from tty]


Ok so, RedHat 9 (obviously).
The screen (not the monitor) will 'sleep', it's not all that annoying, except I've been playing games with a joystick lately, and apparently, RH only cares about Mouse or Keyboard.

So, this happens from both the virtual terminal, and from fluxbox. Any ideas how to stop it?
 
Old 01-24-2004, 03:36 PM   #2
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
In my system, the screen sleep mode is part of the power saving options in the screensaver:

start>preferences -> screensaver icon

you'll find options to turn the whole screensaver off in here as well as change the power options. Does this help?
Simon
 
Old 01-25-2004, 05:50 PM   #3
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
No. That doesn't help.
TTYs (Virtual Console) don't have any buttons.
Fluxbox doesn't have a start button either.

I don't have KDE or GNOME installed, and I'm fairly sure that's what you're using.
 
Old 01-25-2004, 09:27 PM   #4
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
No GUI at all?

You have a screensaver?

Otherwise, look in the CMOS setup under power management, there will (may?) be something in there which blanks the screen after x mins.

Have you tried...

(1) "apropos screensaver" and see what you get ... then do "man <likely utility>" for more information. If you have a screensaver installed you'll also have a command line utility to control it. On my machine, the screen blanking can be controlled from here.

(2) Also try "apropos power" and likewise.

In my machine, bios advanced power management is handled with utilities like apm and apmd... for eg: "apm -i" tells the system to egnore APM suspend and standby events when on AC power.

Other than that - dunno.
Simon
 
Old 01-26-2004, 08:53 PM   #5
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
I didn't say I didn't have a GUI. Unless Fluxbox doesn't count as a GUI (a WM maybe? I'm never sure).

But no, I don't have KDE or GNOME, and if there's any settings in just XFree, I don't know about them.

If this doesn't work, I suppose I could go check the XFree conf.

I totally forgot to check the BIOS.
I'll start with that, thanks.
 
Old 01-27-2004, 04:43 AM   #6
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
re: fluxbox . . . exactly! So you don't HAVE to use the vertual console right? So some where you have a utility, normally stuck in the environment settings somewhere, which controlls the screen. It is often associated with the screensaver. Sheesh!

In my machine (Gnome - yes) there is a launcher on the desktop called "start here" and a menue uption on the panel at the bottom of the screen (or wherever I want it today) called "Preferences". However - linux and gnome are so configurable that these things could be anywhere on anybodies system. ANY advice can only be general finger-pointing.

Anyway - the bios settings are most likely cause, and the screen controls normally read and adjust those.
Simon
 
Old 01-27-2004, 02:19 PM   #7
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
My BIOS doesn't have an option for sleeping the monitor. I suppose I could get the rpms for gnome or kde and give it a quick whirl.
 
Old 01-29-2004, 04:43 PM   #8
VxJasonxV
Member
 
Registered: Apr 2003
Location: Mesa, AZ
Distribution: RH9, LFS5, Knoppix 3.2/3.3 (Live), FC1, FC2, MDK10CE, MDK10OE, Gentoo
Posts: 51

Original Poster
Rep: Reputation: 15
Don't need GNOME or KDE to run xscreensaver, whee.
Well, I disabled the screen saver, and it still happens. And I've shut off all BIOS power management... grr.

I guess the next thing to try is to check apmd settings?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Monitor Refresh Rate on TTY WolfBLN Linux - Hardware 1 06-17-2005 08:07 AM
How to disable the Monitor Sleep function under RH9 ?? 242VDM242 Linux - Newbie 1 05-21-2005 01:51 PM
Monitor: Sleep Mode jsi386 Linux - Newbie 1 01-06-2005 03:51 AM
Putting monitor to sleep cothrige Linux - Newbie 3 03-10-2004 10:07 AM
Monitor Sleep Mode qsilver Linux - General 1 07-21-2001 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 09:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration