LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   Crashed file system (https://www.linuxquestions.org/questions/red-hat-31/crashed-file-system-234112/)

jonthelam 09-23-2004 12:36 AM

Crashed file system
 
I've done some search on here and found some relevant posts, but no answers to this problem. I installed FC2 on my Dell Inspiron 8100 laptop about 2 days ago and everything had been running fine. I leave my laptop on 24/7 since I'm running it as my web server. Last night I discover this error message repeated on my screen countless number of time.

Code:

Ext-fs error (device hda2) in start_transaction: Journal has aborted
I'm not able to reboot this server or issue any type of command so I am forced to cold boot the system. Upon restart the server is back up for a couple of hours and this error shows up again.

Is the hard drive bad? The hda2 partition is my / partition. My next step will be replacing the drive if I can't figure this out.

EDIT: The kernel I'm running on right now is 2.6.8-1.521.

gredhat 09-23-2004 04:11 AM

Hi,
Well it looks like there can be bad sectors in the hard drive. I guess this error usually occurs because of bad sector. You should first check disc for bad sector.

jiawj 09-23-2004 04:25 AM

expect the message to be useful for you

https://listman.redhat.com/archives/.../msg00054.html

SiLiCoN 09-30-2004 06:08 AM

hi

boot from the first CD and then when u land up in the shell

#fsck /dev/hda2

that wud be enough

cheers

jonthelam 09-30-2004 02:04 PM

I tried fsck the disk and it gave errors. Yeah its definitely a bad disk. I ran some diagnostic tools on the drive to confirm it. Thanks for all your help.


All times are GMT -5. The time now is 03:34 PM.