Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 05-24-2005, 11:54 PM   #1
LQ Newbie
Registered: May 2005
Posts: 4

Rep: Reputation: 0
changing display


how do i change the display setting from 640x480 to, say, 1024x768?

my video card & monitor is able to take it... i just can't seemed to change it...

i'm using red hat 9...

thanks in advance...
Old 05-25-2005, 01:10 AM   #2
Registered: Apr 2004
Location: Canada
Distribution: Debian
Posts: 124

Rep: Reputation: 15
Are you talking in X? If so, you simply need to edit your xorg.conf or closest friend.
Old 05-25-2005, 01:21 AM   #3
LQ Newbie
Registered: May 2005
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for the reply korozion,

sorry i'm new to linux...

i'm able to change the settings system tools -> kickstart -> x configuration and the configuration is kept in ks.cfg

from systems settings -> display, i can also see that the resolution has been changed to 1024x768

but from systems tools -> screen resize & rotate, i keep seeing 640x480 somehow, the changes are updated...

do i need to restart x server? how do i do that?....

thanks once again...

Old 05-25-2005, 01:23 AM   #4
Senior Member
Registered: Mar 2005
Location: Las Vegas, NV
Distribution: Mandriva Slackware FreeBSD
Posts: 1,468

Rep: Reputation: 48
korozion is correct... You need to edit your xorg.conf file... you can run xorgconf from the command line or edit the file yourself. Did you choose your correct Video card and Monitor during the installation of RH9?

Try looking at your xorg.conf file:

cat /etc/X11/xorg.conf | more

This should give you an indication of your setup....

Check under "Section Monitor" and "Section Device" to see if that coresponds with what your hardware is.

Old 05-25-2005, 01:25 AM   #5
Senior Member
Registered: Mar 2003
Location: Earth
Distribution: Slackware, Ubuntu, Smoothwall
Posts: 1,571

Rep: Reputation: 45
Welcome to LQ. You should provide more detail?
What video card? What monitor? What commands did you try? etc...

And, like korozion mentions, xorg.conf, in some distros, is the file to look into. In Red Hat 9 I believe the file you need is /etc/X11/XF86Config (might be XF86Config-4).

And probably you need to edit the monitor section with the horizontal and vertical settings for your specific monitor as well as the depth and resolution mode lines, like these in my ubuntu system:
Section "Monitor"
        Identifier      "Generic Monitor"
#       Option          "DPMS"
        HorizSync       31-93
        VertRefresh     50-160
Section "Screen"
        Identifier      "Default Screen"
        Device          "NVIDIA Corporation NV25 [GeForce4 Ti 4400]"
        Monitor         "Generic Monitor"
        DefaultDepth    24
        SubSection "Display"
                Depth           24
                Modes           "1280x1024" "1024x768" "800x600" "640x480"
Also, click on the Search button at the top of the page. This question has been asked many, many times.
Old 05-25-2005, 04:13 AM   #6
LQ Newbie
Registered: May 2005
Posts: 4

Original Poster
Rep: Reputation: 0
thanks for the reply, itsjustme... i did a search and wasn't able to use whatever recommendations that was suggested....

thanks kencaz for the reply... a portion of the config is shown below :

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor 1024x768"
DisplaySize 1000 800
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
Option "dpms"

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel 865"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
SubSection "Display"
Depth 8
Modes "1280x960" "1024x768" "800x600" "640x480"

do i need to change anything?

thanks !!
Old 05-25-2005, 04:46 AM   #7
Registered: Jan 2003
Location: Georgia, US
Distribution: RHEL WS4
Posts: 189

Rep: Reputation: 30
I think you may have had the right idea in your first post. You may just need to restart your X server

If you are using gdm, the graphical login, just exit gnome or kde. When you see the login screen hit <ALT>+<CTL>+<BACKSPACE>. That should restart the X server. If you're using the text mode once you exit gnome or kde the X server is stopped, just type startx and you should be good to go.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
changing display manger -- mandrake 10.2/mandriva olubone Mandriva 1 06-27-2005 07:20 PM
Cannot display this video mode, after changing settings elias1693 Fedora 5 11-28-2004 05:54 PM
changing display managers k0ncept0ne Linux - Newbie 1 10-24-2004 11:09 PM
Changing Display Manager!! sanju2k Linux - General 1 09-06-2003 05:06 AM
Display Options - Changing turnerni Linux - Newbie 2 02-26-2001 01:57 PM > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 03:11 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration