LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Red Hat (http://www.linuxquestions.org/questions/forumdisplay.php?f=31)
-   -   CentOS 6 sound issues (http://www.linuxquestions.org/questions/showthread.php?t=4175456030)

PeterSteele 03-29-2013 10:48 AM

CentOS 6 sound issues
 
I've installed CentOS 6.3 and 6.4 (64 bit) on a couple of different systems and I am not able to get sound to work. The system where I'm running 6.4 is a new Dell XPS 8500. The system appears to recognize the sound devices available, including my Logitech USB Audio device:

Code:

#cat /proc/asound/cards
 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xf7210000 irq 32
 1 [NVidia        ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xf7080000 irq 17
 2 [Z205          ]: USB-Audio -  Logitech Z205
                                  Logitech  Logitech Z205 at usb-0000:00:14.0-2, full speed

but I can't get any sound out of either a regular set of speakers or my USB Logitech speaker. I'm no expert, but it appears the kernel has the expected sound modules:

Code:

$ lsmod |grep snd
snd_usb_audio        122027  2
snd_usbmidi_lib        20976  1 snd_usb_audio
snd_rawmidi            22825  1 snd_usbmidi_lib
snd_hda_codec_hdmi    26157  2
snd_hda_codec_realtek    68136  1
snd_hda_intel          27823  6
snd_hda_codec        121518  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              6652  2 snd_usb_audio,snd_hda_codec
snd_seq                55759  0
snd_seq_device          6500  2 snd_rawmidi,snd_seq
snd_pcm                86635  5 snd_usb_audio,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              22411  2 snd_seq,snd_pcm
snd                    69907  27 snd_usb_audio,snd_usbmidi_lib,snd_rawmidi,snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
soundcore              7958  1 snd
snd_page_alloc          8470  2 snd_hda_intel,snd_pcm

Any advice on how to diagnose this issue would be appreciated.

John VV 03-30-2013 02:19 PM

the first thing to check is alsamixer

is it muted

this happens sometimes
try
Code:

alsaunmute

PeterSteele 03-30-2013 06:56 PM

When I run this command I get:

Code:

Found hardware: "HDA-Intel" "Intel PantherPoint HDMI" "HDA:10ec0887,10280545,00100302 HDA:80862806,80860101,00100000" "0x1028" "0x0545"
Hardware is initialized using a generic method

Still no sound though. Then I decided to switch from KDE to Gnome, which has better sound tools, and from there I was able to get my Logitech speaker to work. The onboard sound is still not working, but I'm at least getting something back now. I need to boot the box with a LiveCD and see if I can get sound from that environment. I'm beginning to suspect a hardware problem, although it's a brand new computer and it work for the brief time I had Windows 8 on it.

Another test I need to try is to return to KDE and see if the Logitech speaker is working from the environment now. I may stick with Gnome though. The CentOS KDE envrionment doesn't appear to be very well supported.


All times are GMT -5. The time now is 03:46 AM.