-   Red Hat (
-   -   building rpm dependency question (

Neruocomp 08-26-2005 10:41 AM

Building from src.rpm dependency question
I've build R from the src rpm since I'm running RH EL4 x86_64. It compiled and made the rpm no problem. But now when it comes to installing it, it complains about needing /usr/local/bin/perl. I've looked through the spec file and can find nothing about changing that dependency.

I've tried installing it with force using rpm --ihv --force or rpm --install --force but no luck. Is there a way I can build an empty rpm that provides /usr/local/bin/perl?

Any other ideas?

dfowensby 09-14-2005 07:06 PM

ok. this may sound dumb, but have you tried creating a vacant file with mkdir?

jillande 09-14-2005 10:50 PM

if you want to force it to install that is missing dependencies, you should use the "--nodeps" option. it will not do a dependency check.

when it says perl is needed, does it cite that a perl rpm is missing or that the specific file "/usr/local/bin/perl" is missing? i find its including the whole path a little peculiar.

All times are GMT -5. The time now is 12:44 PM.