LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (https://www.linuxquestions.org/questions/red-hat-31/)
-   -   broken rh9 in 1950r (raid-5, dual-p3, 512M memory)...used to work better than this (https://www.linuxquestions.org/questions/red-hat-31/broken-rh9-in-1950r-raid-5-dual-p3-512m-memory-used-to-work-better-than-this-248422/)

guest22 10-28-2004 12:30 PM

broken rh9 in 1950r (raid-5, dual-p3, 512M memory)...used to work better than this
 
I have an issue similar to some other's I've seen but still getting nowhere, albeit with a few tantalizing clues:

I have an 1850R, RH9 (dual-600M Pentium ///, 512M memory, Raid5 configured at hardware with a "Smart" controller board). I found out about the install issues the hard way, and was able to load the system with a "nousb" and mem-256M. But now it just doesn't work after install. I've probably tried it 12 times to date. Along the way, I upgraded to the lastest ROM for both the system and for the disk controller board - which certainly sped up the entire system a lot until it bombed (it was bombing under the older firmware as well).

Quick background: I used to have RH8 going on the machine, and while it would once in a while flake out it was at least usable (it was not used for anything remotely close to critical until now). But when I tried re-installing RH8, it wouldn't work either, so I took the opportunity to drag out some RH9 cds as long as I wasn't getting anywhere anyway.

I finally got around to manually partitioning the standard recommended partitions manually through fdisk and tried doing an mke2fs on the newly created partitions. Here's where I stared noticing the funky interactions. It does appear to be some sort of a speed issue vs. memory issue for a large chunk of data writing. It's like the kernel is pumping out data too fast for the controller to keep up and doesn't interact with the controller correctly to know when to pause.

Formatting a short parition such as /boot is just fine (and swap). Formatting / starts off just fine, until various behaviors such as kernal panics or just plain lockups without the panic happens (I have had problems even with no hyper-threading, and even booting from the single-processor option that is set up).

Both memory and the Raid controller pass diagnostics, although that may or not mean anything as I bet the kernel is stressing things much more than the diagnostics. And I have the system type set to Linux through SmartStart.

I have seen posts that says there are incompatibilities with later kernels and this hardware, but then others have said they're running it just fine. And it seems that later kernels should have learned from various hardware out there and while this is an antiquated setup, it was reputable in its day.

Anybody have any clues?

Thanks!


All times are GMT -5. The time now is 12:52 PM.