-   Red Hat (
-   -   Booting RHEL 4 from a USB flash drive (

rossjones 11-15-2006 11:05 AM

Booting RHEL 4 from a USB flash drive
What I am trying to do is put something on my Lexar JumpDrive (128MB) that will allow me to boot to an existing Linux partition on my computer. First, some background. I have a dual boot Dell Latitude 610 laptop. The Windows XP partition is encrypted. As a result of this I can't mess with the Master Boot Record. (I tried installing GRUB on the MBR with the loss of my Windows partition; for some reason the commercial encryption software needs to start from the MBR).
I was able to load RHEL 4 onto a Linux partition and using mkbootdisk --iso <boot_version> I was able to create an ISO file that I burned onto a CD. I now boot into Linux by booting off of that CD (that is I start the computer with the boot CD in the drive and have my boot order set to USB, CDROM, C drive). So every time the kernel changes I need to create a new ISO file and burn a new boot CD (the boot CD has about 2MB of stuff on it).
Then I thought, why not do the same thing only from a flash drive? My computer will boot from a USB device. Then when the kernel changes, I only need to update the flash drive and save creating yet another boot CD; plus I can actually use a 128MB flash drive for something useful.
I have casted around on how to do this. I know several ways that don't work. Copying the boot CD onto the flash drive, using mkbootdisk --device <device name for the mount flash drive e.g. /dev/sba> <kernel_version>, and any other combination of arguments for mkbootdisk all don't work. What I am not trying to do is run Linux from the flash drive. I am trying to get the same capability with the flash drive as I have with the CD without continually buring new CDs (environment friendly).
Sorry about the long winded question. TIA.


Lenard 11-16-2006 05:15 AM

Why not just let the Windows bootloader boot RHEL4???

rossjones 11-16-2006 08:31 AM

Thanks. That worked like a champ. I guess that I focussed in on one solution and ignored the obvious. I did have a few alternations to this solution that might be helpful to others. First, I don't have a /boot partition, but doing the same dd command on the / partition worked fine. Second, when I went to edit the boot.ini file in Windows, I could not find it. In XP Professional, Windows hides the file, but it can be edited by opening the control panel and go to system->Advanced tab->Settings under Startup and Recovery->Edit and add the line specified in the link above. Thanks again.


All times are GMT -5. The time now is 11:30 AM.