-   Red Hat (
-   -   apt-get upgrade caused confusion for 9.0 KDE (

spectrumver1 01-09-2004 01:55 PM

apt-get upgrade caused confusion for 9.0 KDE
I upgraded every package on my system over the course of the last two days. It threw my customizations off a little, but I was still sitting at Blue Curve with no menu customizing yet, so I wasn't bothered by this. But it did do something that is bothering me.

I no longer get the normal Blue Curve login screen at boot up. I wonder if this would be because I uninstalled Metacity (I don't use GNOME, so I wasn't sure and just got rid of it). I get the XWindow style login screen. When I enter my info I'm brought to the stock XWindow screen with the single terminal and nothing else. I type startkde and my session resumes.

I'm sure this is an easy fix, which is why I din't feel to bad about asking the question. I would have looked it all up, but this is my production PC (teaches me to get ambitious with my PC's performance during a project...huh?). What's the file I need to look at? Where's it at? Do I need to reinstall anything? I didn't remove any XWindows components, or KDE for that matter, I just upgraded them.

Thanks in advance for the help.


ac1980 01-09-2004 06:36 PM

It's strange that it didn't keep its preferences, however you can run xdmconfig (or gdmconfig, whichever you use) to setup kde as default environment. Hope this will help.

PS: apt-get has (at least on debian) a specific dist-upgrade command to upgrade everything taking care of changed dependances... next time you can try it.

Ice9 01-12-2004 04:35 AM

I might be wrong here but I think Red Hat uses some Gnome specific file for the login prompt, try reinstalling Gnome and see if that fixes the problem.
This is just a guess based upon the rememberance of some reading a while ago .....

jadermf 01-14-2004 03:19 PM

try reinstall xdm
hello friend,

you may try reinstall the xdm package, if im not so wrong it can work for you

kkempter 01-15-2004 07:55 AM

I've seen thin on my own RH 9 box. You need the GDM package specifically the gdmconfig tool. I believe that if you re-inatall gnome and then run the gdmconfig tool you'll be set.

All times are GMT -5. The time now is 03:49 PM.