-   Red Hat (
-   -   Anyone get LSI SAS drivers to load properly? (

JMCraig 06-30-2008 05:08 PM

Anyone get LSI SAS drivers to load properly?
Hi Folks,

I've been fussing with this fine piece of hardware (Supermicro MB w/ LSI SAS1068e RAID controller) and have not been able to get the drivers to work w/ a trial install of RH EL 5 (2.6.18-92.el5). The OS is installed and happy on two SATA drives, but the RAID array--composed of my expensive SAS drives :-( --is invisible (fdisk doesn't list it).

I've got the RH 5 RPM available from LSI. (I tried Debian before without success [no luck building from source as guided by someone who knew how to do it] but I think I may have had the wrong version of the source--it built but the drivers wouldn't load.) I decided to try RH because there was an RPM available:

LSI's Downloads for 1068 controller

The latest stuff from LSI seems to be version 2.6.18-53 (loading the RPM apparently created several directories in /lib/modules) while the balance of the stuff in /lib/modules is under 2.6.18-92.el5 (I don't know if the version number in the paths to the drivers [2.6.18-53] means the kernel won't find them, but I'm assuming that might be so--I'm a DB guy so I'm beyond my knowledge here). The RPM loaded up fine but the /etc/init.d/fusion.mptctl service doesn't want to start (I get this error as part of the startup as well as when attempting manually it after bootup):


[root@superm]# /etc/init.d/fusion.mptctl start
Starting MPT Fusion (ctl) drivers:                        [FAILED]

Not sure what my next step should be.

How do I find any error log entry there may be? (Nothing seems to show up in /var/log/messages.)

Can I just copy the /lib/modules/2.6.18-53.el5 files into the /lib/modules/2.6.18-92.el5 directory (and maybe they'll work)?

Do I need to recompile from source for the particular kernel version I'm dealing with? (If so I'll have to find/hire someone to help with that!)

Any suggestions most gratefully accepted!


JMCraig 07-02-2008 01:50 PM

Got the arrays recognized.
OK. Although I was unable to get the mpt LSI drivers to load, I was able to find drivers that did work (they were already installed--I assume by Red Hat).

Here's what worked (flailing around to arrive at the relatively simple fix omitted!):


alias eth0 forcedeth
alias eth1 forcedeth
alias scsi_hostadapter sata_nv
alias scsi_hostadapter1 megaraid # added this line


install scsi_hostadapter /bin/true
install scsi_hostadapter1 /bin/true # added this line

Ran depmod to rebuild dependencies.

Rebooted and now I can see the SAS RAID arrays as devices via fdisk -l.

erickwellem 07-03-2008 07:57 AM

cannot load LSI SAS megaraid on Fedora 9 installation
Hey, glad to see somebody who did it. Mine is on Fedora 9 installation. Here's my thread:

Can you share with me how to solve this? Thanks so much.


JMCraig 09-24-2008 09:02 AM

Sorry not to be any help, EW. All I know is what worked for me.

Just BTW, when I upgraded to the next kernel: 2.6.18-92.1.10.el5, I lost access to the SAS drives again.

Here's the very terse and unhelpful reply I got from Supermicro support:


You run Linux red hat 5 update 2 kernel, the driver only available for red hat 5.0 or red hat 5.1` update.
And Red Hat support wasn't much help either. After a lot of back and forth (because they didn't pay attention to what I'd sent), I got this:


From the sosreports provided following information was obtained

1)In kernel 2.6.18-92.el5 version the SAS drives were detected by "megasr" driver for MegaRAID SAS 8208ELP/8208ELP card which is LSI Proprietary driver.Please note that third party driver(might have supplied by OEM) which is not shipped with RHEL will remain out of support scope.

2)When ever you upgrade to a new kernel you need to reinsert the driver module for successfully detecting MegaRAID SAS 8208ELP/8208ELP card and connected drives.For this you need to contact the hardware vendor or follow the documentation of driver module.
So, for now, I'm just sticking with the .92 kernel--I don't know where this megasr driver supposedly comes in--something from an sosreport; makes no sense to me.

JMCraig 12-19-2011 04:48 PM

Corrections and final notes
(In case anyone comes looking for info on LSI 1608-based controllers to get an older box working.)

The megasr driver that worked for me is from LSI. It's closed source (as of this writing).

Check out the reply too this thread labeled "Current State of Affairs ..." (it's probably at the very end of the thread--as I don't expect anyone else will post to it):

All times are GMT -5. The time now is 03:52 PM.