LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 06-15-2006, 08:09 AM   #1
livetoday
Member
 
Registered: Jun 2006
Location: India
Distribution: RHEL,Suse,Fedora
Posts: 106

Rep: Reputation: 15
Post --aid switch is not working with rpm command


Hi,,

I am using RHEL 4.0 and trying to install spamassassin from /usr/src/redhat/RPMS/i386 folder. It contains both the required rpms
perl-Mail-SpamAssassin-3.1.3-1.i386.rpm and spamassassin-3.1.3-1.i386.rpm

but when I try to use rpm -ivh --aid spamassassin-3.1.3-1.i386.rpm
it is giving following errors:

perl(Mail::SpamAssassin::Logger) is needed by spamassassin-3.1.3-1.i386
perl(Mail::SpamAssassin::Message) is needed by spamassassin-3.1.3-1.i386 perl(Mail::SpamAssassin::NetSet) is needed by spamassassin-3.1.3-1.i386
perl(Mail::SpamAssassin::PerMsgLearner) is needed by spamassassin-3.1.3-1.i386


I think it should install the depdency automatically when used by --aid switch...or I need to do something else....
 
Old 06-15-2006, 10:50 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
Since you have both rpm packages available install them both at the same time;

rpm -ivh spamassassin-3*.rpm perl-Mail-SpamAssassin-3*.rpm
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I get the rpm command and rpm build command on my Debian box? abefroman Debian 6 11-28-2005 01:38 PM
java .rpm chmod command not working! barabus Linux - Software 11 06-06-2005 02:52 AM
rpm -bp command not working says "-bp: unknown option" Niceman2005 Linux - Software 2 11-08-2004 02:36 AM
rpm --aid problem hemings SUSE / openSUSE 1 10-28-2004 06:37 PM
rpm command not working sanjaya Linux - Software 7 02-20-2004 02:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 10:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration