-   Red Hat (
-   -   a twist on the old Nvidia problem (

goosegg 09-17-2003 10:18 PM

a twist on the old Nvidia problem
trying to install the nvidia drivers on new install of RH9.

I've followed the instructs and received a cc_mismatch error - "bailing out!"

Ok so come here and search it...I learn the 'export IGNORE_CC_MISMATCH=1" trick

It didn't work.

Here's my output

[root@localhost NVIDIA_kernel-1.0-4180]# export IGNORE_CC_MISMATCH=1
[root@localhost NVIDIA_kernel-1.0-4180]# make install
cc -c -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts -Wparentheses -Wpointer-arith -Wcast-qual -Wno-multichar -O -MD -D__KERNEL__ -DMODULE
make: cc: Command not found
make: *** [nv.o] Error 127
[root@localhost NVIDIA_kernel-1.0-4180]#

C'mon folks, HELP!!! I've a got a three year old thats addicted to tux racer!!!

gizmogadgetus 09-17-2003 10:52 PM

Why make?
Any reason in particular for the make command? I thought the script provided by nvidia would take care of building a custom driver if necessary> Just curious...

goosegg 09-18-2003 08:46 AM

There are two files on the nvidia website right now:

nvidia_kernel and nvidia_glx.

I am following the instructions from the nvidia website to install files of that type and thats getting me to the make *** error.

I dunno. I'm just having a lot of problems with redhat and linux.

I have 2 computers that I'm trying to changeover to linux. The one I'm referring to here is athlon 1.1gig, GF4MX440, 320 megs pc100, onboard sound, linksys nic, 30 gig maxtor, gateway ev700 monitor.

The second one had Redhat 9 on it for a while. I got another video card to trade out video cards with the above, another budget one, and redhat goes blank screen immediately if I choose graphical install, or before first boot if I choose text install. it says "no screens" detected.

Its a athlon XP 1700, GF5200FX, 512 pc 2700, ensonique sound, realtek nic, maxtor 40 gig.

The gf5200fx seems to be a problem for more than one distro. I have the same problem with Knoppix 3.2 but was able to install Knoppix 3.1. Go figure.

I don't like Knoppix much...too many programs nad cdroms and dvd drives aren't detected.

Since I'm not having much luck with "easy" installs I might have to go with slackware or gentoo and take a crash course in frustration. At least then I won't be a noob that can't make a noob distro work.

Thanks for any advice. I'm trying to go legal software at home. The only windows I ever bought came pre-installed on a gateway I bought back in '96! I bought Mandrake 8 at the bookstore though!!

arunshivanandan 09-18-2003 08:59 AM

I am writing this is thinking that you will stay with Linux.
I think has the driver for you.It is really a simple task installing this.(If you read README carefuly).
about the other problem,i have posted in a similar thread the answer for your problem.that is
Configuring your videocard in linux is not at all tough these days.I am sure that someone will be able to help you out.

goosegg 09-18-2003 11:57 AM

Thanks for the nvidia link.

On the other, I tried everything except posting the log file. The last line in the log indicates finding the mouse then nothing. I have seen "mode not supported" and "no screens found"

In my mind, i don't think it likes the card-monitor combo. I don't know if that makes sense. I had RH9 on that machine prior to changing video cards. I have selected both the generic VESA and the generic nvidia during setup. Add to that the the newest Knoppix didn't like it either, I could boot into 3.2 under the old config but can't with the new card and no one else is having trouble with fx5200s. I have a couple different monitors... I guess I could try that...kind of a pain though.

Once I get everything set at a base level, then I can try to set up the linux boxes to do everything I do in windows.

Download stuff (irc, gnutella, etc)
Burn stuff (music, iso's, VCD's, etc)
rip DVD's to Divx, mpg
watch dvd's
record and watch TV programs, using a remote control
play fps online games
play instantchess

That will be what determines if I stay with linux. So it took me a long time to figure that in windows, hopefully it won't take as long in linux. I'll give it some time.

arunshivanandan 09-19-2003 09:11 AM

did you try installing the nvdia driver I refered to??There is nothing tough in installing it (just give 'sh <nvidia filename> from text mode)provided you read the README quite carefully.just download it and try installing it.
also,did you try 'redhat-config-xfree86' or 'xf86config'.??
ps:i dont think that someone will be able to help you out without seeing your log file and config file.What prevents you from posting it??just post the trouble and someone may be help you out.

goosegg 09-19-2003 10:25 AM

Yes the link worked for redhat, didn't work for Knoppix. I can't post the log file since I put Knoppix on that machine instead.

arunshivanandan 09-19-2003 10:35 AM

did you try keyword 'nvidia+knoppix' gives a number of results.
try (i read somewhere that everything related to nvidia+knoppix starts from this link)
I have never used an OS bootable from CD except a 190MB slackware live,which I have used a couple of times-no I dont know to help you in the case of knoppix.

bitterjack 09-19-2003 06:45 PM

nvidia-installer BROKE
I have the EXACT same problem trying to install the new nvidia driver ( It will not recognize the kernel header for the 4.20-20.9 kernel update. I even tried the --kernel-include-path /usr/inlcude. It tries to install then but fails. It does not build. It gets all the way to compiling the (nv) kernel but fails because "You appear to compiling the NVIDIA kernel with a different compiler than was used to compile the running kernel." Later I see the error of "failed the cc sanity check."
I tried to enable gcc and butls but I get dependency errors that I can not resolve. It says I need krb5-libs= and openssl =0.9.7a-2. When I try to install the latest RPM's of the above two things, I am told they are already installed. I keep going in a circle and so far no one has been able to help me.
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Fri Sep 19 17:22:12 2003

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel include path : /usr/include
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site :

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site ( (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Using the kernel include path '/usr/include' as specified by the
'--kernel-include-dir' commandline option.
-> Kernel include path: '/usr/include'
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f nv.o os-agp.o os-interface.o os-registry.o nv-linux.o nv_compiler.h *
.d NVdriver nvidia.o
-> Building kernel module:
executing: 'cd ./usr/src/nv; make nvidia.o SYSINCLUDE=/usr/include'...

You appear to be compiling the NVIDIA kernel module with
a compiler different from the one that was used to compile
the running kernel. This may be perfectly fine, but there
are cases where this can lead to unexpected behaviour and
system crashes.

If you know what you are doing and want to override this
check, you can do so by setting IGNORE_CC_MISMATCH.

In any other case, set the CC environment variable to the
name of the compiler that was used to compile the kernel.

*** Failed cc sanity check. Bailing out! ***
make: *** [gcc-check] Error 1
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at

All times are GMT -5. The time now is 04:12 PM.