-   Puppy (
-   -   unable ot install lupu_devx_501.sfs into virtual box hard disk install of puppy 5.0.1 (

sirius57 08-01-2010 09:44 PM

unable ot install lupu_devx_501.sfs into virtual box hard disk install of puppy 5.0.1
I need to compile the guest additions in puppy 5.0.1, but first the lupu-devx_501.sfs needs to be installed because it contains gcc, make, etc. I am unable to attach the .sfs file with puppy's tool to load it and I also tried to make a pet file. I ran the pet file, but I have no gcc or make. I have puppy 5.0.1 in a virtual hard disk install with virtual box 3.0.4 running in opensuse 11.1 64 bit os. The puppy kernel is

8-bit 08-02-2010 11:31 PM

Did you put lupu-devx_501.sfs in the base directory of the virtual hard drive?
That directory on the virtual hard drive is considered /mnt/home.
Also, you may need the kernel source SFS file.

sirius57 08-07-2010 01:07 PM

I found that I have a 'full install' not a 'frugal install' of puppy so the .sfs boot loader will not work on with a full install of puppy. However, I was able to install the lupu_devx_501.sfs file by mounting it and using the method that follows:

place in /
#mount -o loop lupu_devx_501.sfs /data
#cp -a -v --remove-destination /data/* / >devcopy.txt
#umount /data

I also need to install the header files. I copied the .sfs file and need to know how to install the header files with a full install of puppy.

8-bit 08-08-2010 02:35 AM

You might try SFS installer by Trio.
It lets you install the devx SFS file and kernel source SFS file and be able to use it without rebooting. And you are also able to uninstall them using Puppy Package Manager.
It can be found at

sirius57 08-10-2010 08:44 PM

Does puppy come with kernel sources already installed? When I run the guest additions, the log file says 'run make oldconfig && make prepare'. I installed the sfs manager but I did not see the kernel_src- file in the puppy pet manager. I tried to run make oldconfig and get the error message 'no rule to make target 'oldconfig'. How is make oldconfig run and from which directory?

All times are GMT -5. The time now is 11:51 AM.