-   Puppy (
-   -   Puppy Linux: problems with dial-up and router connections on XP PC (

Peter Rosier 07-16-2008 10:46 AM

Puppy Linux: problems with dial-up and router connections on XP PC
Please help if you can as I am new to Linux! Thanks...

I have burnt a copy of Puppy Linux 4.00 to CD and it boots quickly in my old PC (from the CDROM drive) that runs Win XP (badly as it will only run in safe mode, no networking). Puppy is fast, clear and versatile BUT it cannot get on to the internet via the router I use for my new PC although the Puppy wizard, using auto DHCP, says OK and the browser symbol shows the internet connection made. As a fall-back, Puppy used to recognise a dial-up modem and could use that at first but now it can't find that either even though I plug it in before booting Puppy. So neither way can I get on the internet with my old PC.

But, if I run Puppy from its CD on my new machine (Win Vista) via the router it connects instantly to broadband - perfectly! So router and Puppy work together but not on the old machine (when loading, Puppy says networking is 'backgrounded' - any clue there?)

My guess is that because Win XP is damaged and itself can't get on to the internet (NT Administrator closes it down each time and it seems the safety centre is lost/ corrupted), it may be it has shut the door for Puppy, too.

The configuration software for the router used in Windows on my old PC says there is no connection between the PC and the router although the cable is plugged in to the ethernet card. If the ethernet card used to contact my router is closed down (by XP?) and Puppy can't open it, might a USB plug-in "USB to ethernet" connector work (I only saw these advertised yesterday)?

I want Puppy to make the old machine a good second PC but XP may be spoiling the show! Any advice/ thoughts, etc very welcome.

Thanks again.

pruneau 07-16-2008 10:55 AM

That sady looks likes puppy did not detect the network card.
If you go to the command prompt (as root), and try "ifconfig -a", what does it give back ?

Peter Rosier 07-17-2008 08:04 AM

Thank you, Pruneau.

Before attempting to connect to the internet it replies:

1o Link encap:Local loopback
inet addr: Mask:
RX Packets:0 errors:0 dropped:0 overruns:0 frame:0
TX Packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0B) TX bytes:0 (0.0)

After two connection attempts, replies are the same except:

RX Packets:16
TX Packets:16
RX bytes: 1200 (1.1KiB) TX bytes: 1200 (1.1KiB)


RX Packets:24
TX Packets:24
RX bytes:1768 (1.7KiB) TX bytes:1768 (1.7KiB)

No website can be reached from the browser. The "internet connected" logo in the browser showed OK even though the PC wasn't at that point plugged in to the router, so that's not a totally accurate guide!

One extra bit of info. I changed the motherboard on this old PC and had to reinstall WinXP but this caused the ECS motherboard to lose its built in driver for sound. I couldn't restore this for Window's operation but Puppy did it in two clicks from its own desktop and now sound in LINUX is fine. Maybe the motherboard driver for the ethernet card (VIA s/ware, I think) also was deleted. Again, can't seem to reload it from the ECS (motherboard) site but, if Puppy has an ethernet driver (like it had for the sound card)or this can be by-passed?

Thanks again.

polarbear20000 07-17-2008 01:03 PM


Originally Posted by Peter Rosier (Post 3217568)
Before attempting to connect to the internet it replies:

1o Link encap:Local loopback
inet addr: Mask:
RX Packets:0 errors:0 dropped:0 overruns:0 frame:0
TX Packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0B) TX bytes:0 (0.0)

I use Puppy on my older computers. I do not see that the ethernet card is up - so run the Ethernet wizard. It'll test for an alive network/card/connection and *should* set it up. Be patient - it is a little slow and careful, but you should be able to get it.


pruneau 07-18-2008 08:21 AM

Lo is not enough.
Well, if what your showing of the ifconfig -a output is all, this means that your network hardware was not detected.

You need something like this:

eth0 Link encap:Ethernet HWaddr AA:BB:CC:DD:EE:FF
inet addr:XXX.YYY.ZZZ.TTT Bcast:XXX.YYY.ZZZ.TTT Mask:
inet6 addr: ffff::fff:ffff:ffff:ffff/64 Scope:Link
RX packets:33977576 errors:0 dropped:0 overruns:0 frame:0
TX packets:17895969 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1066250025 (1016.8 MiB) TX bytes:3239707715 (3.0 GiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:40556190 errors:0 dropped:0 overruns:0 frame:0
TX packets:40556190 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3472922971 (3.2 GiB) TX bytes:3472922971 (3.2 GiB)
Now, the answer above suggested a wizard to detect your network hardware.
If after starting the wizard, it does not suggest anything else that lo, you will have to instruct it to load a module, there is a button for that.
Use "lspci" in a console to see what card you have installed, and then a little googling should find which module you have to load into the kernel to make it work.
Once you card is activated, you just have to instruct the wizard to save your configuration and you should be surfing the wwwaves in no time.

Peter Rosier 07-18-2008 10:34 AM

Ethernet drivers
Thank you both sincerely for your help here.

The console did not recognise the command Ispci (or maybe I misunderstood) but info on the ECS motherboard site indicates VIA software is used to drive the ethernet which is all part of the motherboard, ie no separate plug-in board. There was a choice of three drivers on Puppy for VIA but none allowed the connection to be detected.

I think the answer might be to buy a cheap ethernet board so I KNOW what type it is and then ask Puppy to load the right driver. I'll be sure then.

Anyone had any experience of the USB to ethernet converters? Local computer store has no experience of them for LINUX, not surprisingly, and doubted if they would work.

Peter Rosier 07-21-2008 08:54 AM

Success at last!
Thank you Polar Bear and Pruneau for your advice and encouragement.

Well, I'm pleased (no, make that delighted!) to say that I have got my old PC on-line with Puppy and yah boo sucks to Win XP that it used to run and that took forever to load and then refused to do anything outside safe mode, etc, etc.

I can't pretend I was able to undertake any deeply technical analysis here. From your advice, I figured that if the Puppy couldn't seem to work with the ECS motherboard's own ethernet built-in, I'd buy a new board (Edimax10/100, EN9130). It has a driver for LINUX but the drivers are on a hard shell floppy which I can't read now but Puppy found a driver amongst its many. So high hopes but, no, it STILL wouldn't connect, tried auto DHCP and manual settings, etc. No dice.

Then laying in bed thinking about it (sad, I know), I just wondered if, as I had originally set up the hard-disk file to save my settings and part of the boot-up of Puppy (as Puppy helpfully suggests), that might have useless and inaccurate comms data stored from my earlier fruitless attempts which was confusing the issue now I had a good ethernet board. Even to me, that sounded pretty desperate but, nothing to lose, I mounted 'Maxtor', the hard drive make, from Puppy desktop and found the Puppy stored file amongst the Windows ones listed and deleted it. Rebooted and did the internet connection wizard thing with auto finding of settings (as many times before), clicked on the browser, had no hopes that it would work and bingo, the website I entered came up. Not only that, but loading of websites seems much faster than under Windows - but that might be just the internet conditions at present.

Anyway, I'm thrilled because (a) I hate to be beaten and (b) I hate to spend 13 on what would have been a nugatory purchase of a new ethernet board and (c) I now have a super working PC which is quick and stable from:

- one old PC I bought second or third hand 4 years ago and have used with XP very hard ever since;

- one new (to me) motherboard with twice the speed and four times the original RAM I bought for 30 on ebay and fitted;

- one copy of Puppy LINUX, f.o.c. downloaded from one of the links,

- one ethernet board 13.

This is the equivalent of a 250 value unit here in the UK.

Can't be bad and I'll have fun exploring all aspects of Puppy.

Seriously, though, if anyone does have a problem like this, maybe deleting the saved settings file and starting again may help you. Worth a try.

Thanks again!

polarbear20000 07-22-2008 12:05 AM


pruneau 07-22-2008 09:49 AM

Well, thanks for the feedback, I'm pretty sure that some other puppy user are going to find this useful. It was a pleasure: it's always easier to help people who wants to help themselves, anyway.
Oh, and btw, beds and bathtubs are most certainly the best places to think ;)

All times are GMT -5. The time now is 09:31 AM.