-   Puppy (
-   -   Newbie; Can't install from CD; "Kernel Panic" (

patanderson1990 07-14-2013 12:14 AM

Newbie; Can't install from CD; "Kernel Panic"
Hi all,

I am a rank amatuer when it comes to linux in general and puppy in particular. I installed Ubuntu 12.04 on my computer a month ago, and I was impressed. I then decided to try out puppy linux on the same machine. To that end, I acquired 2 CD's of puppy -- 1 precise 5.6 which I bured my self and 1 slacko 5.5 which was burned for me. I have attempted to boot both CD's. In each case, I get an error along the lines of 'sync failed, kernel panic...attempted to kill init!'. I tried looking around on the web for solutions. A lot of people suggest simply typing things like "pfix=ram" into the command line. However, when I try to type that into what I THINK is the command line, all of my '=' keystrokes come out as "+"'s. I then have to cut power to my computer, reboot, and try again.

If someone could give me an absolute idiot's guide to making this work, I'd really appreciate it. I was really excited about trying Puppy Linux, but thusfar its been a major letdown not even being able to boot it up. Thanks in advance for your help!

Ser Olmy 07-14-2013 01:05 AM

The keyboard problem is due to the fact that the boot loader command line uses the US keyboard layout, while it seems your keyboard has a different layout. You just need to find the right key. The US layout has "=" on the second key from the right on top row, next to the Backspace key.

It's hard to say what's causing the kernel panic without seeing the exact error message, including any messages immediately above the "kernel panic, attempting to kill init" line.

patanderson1990 07-14-2013 01:23 AM

Thanks for the response, I appreciate it.

I'm using a standard UIS keyboard, its just that the '+' and '=' are on the same key. Maybe I'm thinking that the wrong area is the command prompt, because it seems like it just capitalizes everything that I type in that area. I've been using the area below the puppy logo that shows up during the initial stages of booting puppy. Is that the command prompt, or am I mistaken?

As for the error message, here's what I got just now.

It loads some files to RAM, and then,

"setting up the layered filesystem..."
"Performing a switch_root to the layered filesystem..."

"[72.167426] Kernel panic - not syncing: Attempted to kill init!

[72.1675058] Pid: 1, comm: switch_root Not tainted 3.2.44 #1"


There are a few more lines below that that seem to reference the error. Do you need those as well? I just wanted to get a reply to you ASAP so I can resolve this as soon as possible.

Ser Olmy 07-14-2013 01:57 AM

"+" and "=" is indeed on the same key, but the "+" is only supposed to appear when you're holding down shift. Could one of your shift keys be stuck, by any chance?

While I know absolutely nothing about Puppy Linux, it seems pretty clear that the initrd on the CD tries to set up a UnionFS or AuFS "layered" filesystem in RAM (probably combining files in RAM with files from the CD into one file system), but something goes wrong and the resulting file system can't be mounted.

It's hard to say what's causing this, but it could very well be a problem with the CD itself. Have you tried booting the CD on another computer?

jefro 07-14-2013 10:45 AM

If you installed ubuntu then at one time I'd think this system was OK. Now you can't install two of the most basic distro's for some reason. Suspect some change. That change could be cd reader to memory to psu or any part inbetween. Test first with memtest.

As always, consider the disc's to be bad as well. Either poor quality or poor burn or bad data to begin with.

Karl Godt 07-23-2013 05:35 AM

Maybe a bit late :

really check md5sums .
a download that is slightly too short would probably result in a not mountable .sfs inside .

sometimes there are issues with ACPI . OF COURSE donīt tell anybody about the specifications of your HW .
NEVER look into some kind of menu.lst or grub.cfg in the /boot/grub folder of a LINUX that boots for hints about kernel parameters other distros use .


All times are GMT -5. The time now is 04:46 AM.