-   Puppy (
-   -   Network Problem (

wolfmack 11-12-2010 01:43 PM

Network Problem
I recently installed Puppy Linux on my Acer Aspire One. I have tried connecting to a number of un-encrypted wireless networks and to my router with an ethernet cable. The system regognizes the network, but an error appears stating that the DHCP client failed to negotiate with it. I tried adding the pet pack update thing from the website, but it didn't solve the problem. Does anyone have suggestions? Please explain in simple terms. Thanks.

business_kid 11-12-2010 01:57 PM

Welcome to LQ.

Wireless, it could be a whole host of reasons. A good site

Have you a network card(& cable it in) so you would run
dhcpcd eth0
Or a wifi card
dpcpcd wlan0

Linux drivers need firmware. As root, run
and see what your network cards are. For cable, you need
1 Kernel module
2. Firmware

business_kid 11-13-2010 07:36 AM

hmmph! That link didn't appear
A good site for wireless

wolfmack 11-15-2010 09:23 PM

it started working better now. Thanks for your help

johnywhy 09-11-2011 11:45 AM

I'm experiencing the same, on puppy lucid 5.2.8.
I have no connection issues on 5.2.5. In fact, had no connection issues on this 5.2.8 after installing, but now won't connect.

Dpcpcd and ispci return 'command not found'.

This is a netbook.

business_kid 09-12-2011 03:16 AM


Dpcpcd and ispci return 'command not found'.

This is a netbook.[/QUOTE]

OK, No dhcpcd? Have you dhclient? that's the same, same options etc.

The copmmand is lspci, that is L(for Lucifer)spci, like the command ls. Sorry if I wrote it otherwise.

johnywhy 09-12-2011 10:46 AM

I resolved it by installing and using frisbee.


All times are GMT -5. The time now is 12:06 AM.