LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Puppy (https://www.linuxquestions.org/questions/puppy-71/)
-   -   Lenovo s10 WiFi in Puppy 4.31 (https://www.linuxquestions.org/questions/puppy-71/lenovo-s10-wifi-in-puppy-4-31-a-770954/)

TheHimself 11-23-2009 06:34 AM

Lenovo s10 WiFi in Puppy 4.31
 
I know that there are many posts about this. I've tried both the "hybrid" driver and the one supplied by Tempestuous. For the latter one, the .pet file gets installed "successfully" but when I want to load the module in network manager I get the message "can't find the file" or something like that. For the hybrid one the command
Code:

insmod wl.ko
returns an error saying the module is not the right format.

What am I doing wrong? Something weired which might be related to this is that when I write to my home folder I realize that it goes to
/mnt/home/home/ I thought one didn't have to mount their own home folder.

exvor 12-14-2009 08:46 PM

Where did you get the hybrid driver? Did you download it directly from broadcom or did you get it from some puppy repository. I am familiar with the driver not with puppy in this area.

8-bit 12-15-2009 04:31 PM

I have had insmod not work for me too with same error message.
Try depmod from the command line and then modprobe wl.ko
Maybe you can get lucky.
You might also be able to use the windows drivers for it using ndiswrapper to load them.
I used the windows drivers with ndiswrapper for a linksys USB wireless device and it worked.

TheHimself 12-16-2009 11:41 AM

I downloaded the hybrid driver from Broadcom. The windows driver does not have the right extension(!) The extension was ".sys" I think.

8-bit 12-16-2009 11:58 AM

Have you tried downloading the Windows driver for it and using ndiswrapper and then selecting the inf file for it?
I know that sometimes getting wireless devices to work is a real pain.
But the driver should have an inf file if you downloaded the one for windows. You select it instead of the sys file.

bobbio 12-22-2009 10:05 PM

bcm4312 wireless fix for lenovo s10 in puppy 4.31
 
jrb in the puppy forum; hardware>networking has a remastered 4.3.1
iso available with a working wireless module in network wizard for
lenovo s10. No ndiswrapper required.

exvor 12-23-2009 06:06 PM

Quote:

Originally Posted by TheHimself (Post 3793970)
I downloaded the hybrid driver from Broadcom. The windows driver does not have the right extension(!) The extension was ".sys" I think.

Huh? Download the Linux driver on the broadcom site. You have to compile it tho, so you will need to have more then what puppy comes with by default. If you want I can email you a good wl.ko that should work if you are using a recent kernel. If not then you may need to grab gcc and the kernel sources to be able to compile it.

puppyite 01-03-2010 06:24 PM

AFAIK Lenovo is Linux compatiable therefore Puppy should be able to find your wireless card. Look here for how to.

TheHimself 01-11-2010 06:35 AM

Than you guys. I did what bobbio suggested and it now works.


All times are GMT -5. The time now is 04:26 PM.