-   Puppy (
-   -   Install on Dell Latitude LS (

Cockney Rebel 09-08-2007 06:10 AM

Install on Dell Latitude LS
I am trying to install 2.17.1 on a Dell Latitude LS, however I am unable to run the live CD which has worked on my Desktop and another laptop.

Details are:
Dell Latitude LS
PIII 500
128 Mb RAB
10 Gb HD
Windows 2000

On booting from the CD I get the following messages:

Looking for puppy in hdc done
Error cannot find puppy on 'cd' boot media

Exited to initial - ramdisk (init ram fs) command line ...
(the linux - guru can now debug 'e3' editor is available

/bin/sh: can't access tty; job control turned off

Any ideas on why the live won't install here when no problem on 2 other machines. I'd really like to get a quick running system on this old wreck, and like the look and speed of Puppy.

Simon Bridge 09-08-2007 08:53 AM


Looking for puppy in hdc done
Error cannot find puppy on 'cd' boot media
I take it you tried booting another laptop with this same disk right after you saw this?

Normally I'd suspect that the CD-drive wants some special treatment which is not available in the kernel. But this is an old machine...

I'd try something like DSL, just to have something booting, to verify the hardware.

Cockney Rebel 09-09-2007 12:29 AM

I've booted the Puppy disk on my desktop machine and another laptop, and DSL boots on the Dell, I could go down that root but I like the look and feel of Puppy better.

Simon Bridge 09-09-2007 03:52 AM

I can understand that.

The issue is in the IDE controller or the optical drive on the dell. It needs something that puppy install kernel doesn't have. You will have to try fiddling the boot parameters...

puppy noapic nolapic noacpi ide=nodma

... of course, it could be that the cdrom is not hdc. Can you check that, using DSL, for me?

Cockney Rebel 09-11-2007 03:32 AM


Thanks for your response, on booting from DSL the boot media is found at: dev/scd0 so it seems your correct that its the boot device that Puppy isn't finding. Can you tell me how to tell Puppy to look in the correct place for the boot media?


Simon Bridge 09-14-2007 12:46 AM


puppy pmedia=idecd

at the boot: prompt is supposed to get puppy ransacking your IDE cd drives for the files. But you may end up editing isolinux.cfg on the iso to get it going.

Cockney Rebel 10-16-2007 10:30 AM


I should have replied before, I have now installed Zenwalk and it all went fine. Thank you for your time.

Simon Bridge 10-18-2007 05:08 PM

Cool... zenwalk is nice too.

All times are GMT -5. The time now is 11:17 AM.