-   Puppy (
-   -   Grub error 17 (

cov 10-07-2007 03:46 AM

Grub error 17

I have been wrestling with this for a couple of days now.

I have used the Universal Installer to put Puppy on /dev/hda3 which has ext3.

When I reboot I get the following:


GRUB Loading stae 1.5.

GRUB loading, please wait...
Error 17

and then it hangs.

I believe that error 17 indicates that Grub cannot mount the selected partition.

My /boot/grub/menu.1st looks like this:

title W98 (on /dev/hda1)
rootnoverify (hd0,0)#I realise this should probably be just 'root'
chainloader +1

title Puppy (on /dev/hda3)
root (hd0,02)
kernel /boot/vmlinuz root=/dev/hda3 ro vga=normal
If I run 'grub-install /dev/hda3', I get '/usr/lib/grub/i386-t2/stage1: Not Found'

So I symlink '/usr/lib/grub/i386-t2/' to '/usr/lib/grub/i386-pc/' which gives me the following when I run grub-install again:


Could not find device for /boot: Not found or not a block device.
Can anyone help?

cov 10-07-2007 04:07 AM


The Last post on this thread
refers to Partition Magic corrupting the MBR. (The link to the wiki in the same post did not help, however)

It looks like the only answer is to scrub the Hard Drive and start again....

syg00 10-07-2007 04:20 AM

You should never need to do that. From a (linux) terminal/console let's see the output from "fdisk -l"; you may need to be root.

cov 10-07-2007 04:35 AM

Well my fdisk -l output is as follows

Disk /dev/hda: 80.0GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 255 2048256 b W95 FAT32
/dev/hda2 256 2624 19028992+ 83 Linux
/dev/hda3 2625 6177 28539473+ 83 Linux
/dev/hda4 6178 9729 28531440 f W95 Ext'd (LBA)
/dev/hda5 9469 9729 2096482+ 82 Linux swap / Solaris
/dev/hda6 9407 9467 489257+ 83 Linux

Partition Tables are not in disk order
I can't see too much wrong there, can you?

syg00 10-07-2007 04:49 AM

I prefer the "native" grub commands rather than the grub-install wrapper. Try this

root (hd0,2)
setup (hd0)

Then reboot.

cov 10-07-2007 05:06 AM


root (hd0,2)
Filesystem type is ext2fs, partition type 0x83

setup (hd0)
Checking if "/boot/grub/stage1" exists... yes
Checking if "/boot/grub/stage2" exists... yes
Checking if "/boot/grub/e2fs_stage1_5" exists... yes
Running "embed "/boot/grub/e2fs_stage1_5 (hd0)"... 16 sectors are embedded.
Running "install "/boot/grub/stage1 (hd0) (hd0)1+16 p (hd0,2)/boot/grub/stage2 /boot/grub/menu.1st"... succeeded
Grub Error 17 still occurs as previously.

The more I think about it the more I think that Partition Magic is responsible.

syg00 10-07-2007 05:17 AM

No, PM screws things in other ways. Change the "root (hd0,02)" in menu.lst to "root (hd0,2)" and try again.

cov 10-07-2007 05:24 AM


Originally Posted by syg00 (Post 2916007)
No, PM screws things in other ways. Change the "root (hd0,02)" in menu.lst to "root (hd0,2)" and try again.

That was a typo by me (the puppy machine doesn't have a network connection and I'm transcriping from one machine to another)

cov 10-07-2007 06:00 AM

Okay, I'm not wasting any more time on this.

I'm going to "dd if=/dev/zero of=/dev/hda bs=512 count=1" and start again.

cov 10-07-2007 05:17 PM

I've zeroed the hard drive and reinstalled everything.

It now works.

I suspect it was caused by Partition Magic...

All times are GMT -5. The time now is 04:52 PM.